Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Im trying to install powershell 3.0 on my Win7 64 bit pc, but I get the error "the update is not applicable to your computer."

After googling the error, all the solutions I see are that you need to install .net 4 full profile.

However, .net 4 won't install, as I have .net 4.5 installed. I did a repair on .net 4.5 to see if that would help, but it didnt.

Anyone know of a solution? Im wondering if I have to uninstall .net 4.5 and 4 and reinstall them.

Update: I uninstalled .NET 4.5 and 4 and reinstalled the 4.0 full profile - no luck I double checked I had the correct version for Win 7 64 bit - I do...

share|improve this question
How can we help you if you don't provide the installation error codes? – Ramhound Jan 25 '13 at 17:59
there are no error codes, as there are no errors other than "the update is not applicable." – Keltari Jan 25 '13 at 18:07
.NET Framework 4.5 is an in-place replacement for .NET Framework. So having .NET Framework 4.5 is NOT the reason this installer is failing. Are you saying that the installer doesn't even start AT ALL? – Ramhound Jan 25 '13 at 18:08
The logical solution would be to get rid of .NET Framework 4.5 replace it with .NET Framework 4.0 then see if Powershell 3.0 would install. At that point you could install .NET Framework 4.5 and verify thats indeed the reason the installer wasn't working. I don't meant to sound short by when I am able to find tons of information on how to solve this problem, it makes it look like, you didn't research the problem before you asked for help. You should read and – Ramhound Jan 25 '13 at 18:48
If you don't answer my important questions I can't help. – Ramhound Jan 25 '13 at 20:57

Check you don't have a pre-release version installed. If so, uninstall it first then try again.

Alternatively, if you're absolutely sure you have all the pre-requisites in place, there is a possible workaround:

Unpack the EXE as if it were a ZIP file (I used 7-zip), open CMD in the same directory, then run the following substituting the name of your extracted CAB file:

start /w %SystemRoot%\system32\pkgmgr.exe /ip /

Wait until prompted to reboot, then reboot.

Source: Microsoft Connect - Quote was posted as a workaround and has been edited slightly to improve grammar

share|improve this answer
I gave it a shot, seemed promising, but eventually errored out with "can not find specified file" ] – Keltari Feb 4 '13 at 22:16
up vote 1 down vote accepted

I finally got Powershell 3 to install! This was a complete PITA.

To be honest, Ive tried so many things and got so many errors, Im not entirely sure what did the trick exactly. I dont know if all the steps were necessary, but in the end it ended up working.

  • Uninstalled .NET 4.5
  • Uninstalled .NET 4
  • Uninstalled any other .NET related applications such as SDKs and some other things
  • rebooted
  • Installed .NET 4 Full client profile for Win 7 64 bit
  • Installed patches to .NET 4
  • rebooted
  • extracted the .CAB files from the installer for Powershell 3 for Win 7 64 bit
  • ran pkmgr on the extracted .CAB file (I dont think this helped, I know it failed in many attempts while trying to get it working)
  • ran wusa.exe on the extracted .CAB file (I think this is what did it in the end) got a reboot notification
  • rebooted
  • ran a get-host in powershell and it returned version 3. (woohoo!)
  • reinstalled .NET 4.5
  • installed patches for .NET 4.5 rebooted
  • ran a get-host in powershell and it still worked returned version 3 (phew)
share|improve this answer
I don't feel safe uninstalling frameworks ;( – BjarkeCK Oct 21 '13 at 8:21

Whenever I get this error it's because I accidentally downloaded the wrong version, since I'm on x64 also I d/l the x86 version or ia64 version by accident. Could that be the case? simplest things first I suppose :-)

UPDATE Due To More Information

Also, MS says .net 4.5 works fine, so no problem there

share|improve this answer
double and triple checked I have the right version... I do. – Keltari Feb 4 '13 at 22:14

I have windows 7 home premium. I had the same issue and found a solution that worked for me in a book I purchased. The book is "Learn windows PowerShell 3 in a month of lunches". (second edition)In Chapter 1, 1.5 it states that PowerShell 3 requires .NET Framework v4. I downloaded it from Microsoft website and then I was able to download and install PowerShell 3 without any error.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.