Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a frustrating network connectivity issue on my work machine. It's not a crippling problem, but it's driving me bananas, and I would love some advice on how to diagnose the issue.

Whenever I walk away from my computer, I habitually lock it (usually using Win+L). When I return to my computer, whether it be minutes or hours later, and unlock it, I experience a dropped network connection.

I noticed at first when I'd come back, load up a website, and it would time out. After a while, I started looking at the network icon on my taskbar. Sure enough, it would indicate that there was no network connection. Then it will search for a connection, find it, and reconnect. Sometimes, it immediately loses the connection again, and then has to re-establish it. It's usually all over and settled down within 30-60 seconds, and experiences no more problems until the next time I unlock the machine.

This never happens while I'm using the machine; only immediately after I unlock it. No one else in the office has reported this issue. We have no dedicated IT staff; the IT responsibilities are shared by the software engineers, of which I am one.

I have no idea how to go about diagnosing this issue, and I would welcome any advice or ideas. Here are the salient specifics of my configuration:

  • Win7 Pro, 64-bit
  • Domain network membership
  • Intel 82579LM gigabit network adapter
  • Wired connection
share|improve this question

migrated from serverfault.com Jan 25 '13 at 21:34

This question came from our site for professional system and network administrators.

add comment

2 Answers 2

Check the NIC driver settings and see if the Power Settings can turn the device off.

(This question is borderline for voting to move to SuperUser, but since you're acting as the IT guy, no biggie. Everyone needs to start learning somewhere.)

share|improve this answer
    
I've disabled "Energy Efficient Ethernet", which is the only power setting that indicates it can spin the device down...will let you know if this helps. Thanks! –  Ethan Brown Jan 25 '13 at 23:14
    
Nice idea, but not the problem...I made sure there aren't any settings that's allowing it to go sleep, and the problem persists. Good suggestion, though! –  Ethan Brown Jan 27 '13 at 1:33
    
That's not the setting I meant. In Device Manager, go to the NIC. The last tab should be Power Management. Uncheck "Allow the computer to turn off this device to save power." –  mfinni Jan 27 '13 at 15:48
    
That's what I did...the last tab is indeed "Power Management", but it's a custom Intel tab, and there is no option "Allow the computer to turn off this device to save power", only the options I described above. –  Ethan Brown Jan 28 '13 at 17:53
add comment

As a way to help track down when the problem starts, try a simple ping from another machine and see when it goes offline in relation to when you lock the desktop. It might give you some insight as to why it is doing it.

share|improve this answer
    
Good suggestion, Mike, I will do this on Monday and let you know how it goes. –  Ethan Brown Jan 27 '13 at 1:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.