Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The fibreop router provided by my ISP is not dual band, so I just bought a dual band router, turned off the wireless signal on the ISP router (which is still the one connected to the modem), connected the new one to a LAN port, and voila, I now have my proper dual band network and its working GREAT.

Problem is, my network now seems to be "segmented". All the devices connected to the wifi (the "new" router) can (of course) see the new router (LAN ip 192.168.0.1), and can see the media server on it.

The main computer, however, which is the other LAN device on the "main" router, cannot connect to the new router, either via the 192.168.0.1 ip or the assigned 192.168.2.15 ip (which I see on the "main" routers config settings for its LAN status, which I CAN access from the main computer).

I just want to be able to keep the existing (mostly working) setup, but also be able to put stuff on the media server from the main computer, so I can see it on the other devices... Is there some configuration missing on the "main" router that's not providing a route between the two devices on its LAN ports?

Any input would be appreciated.

Thanks!

-Shawn

share|improve this question
    
Since you have two routers and you have not mentioned it, there are probably two DHCP servers running on your LAN. You need to disable the DHCP server on your new dual-band router so that it does not conflict with the ISP's router. Also be sure to assign the dual-band router a static IP address that is outside the DHCP range yet still in the subnet (or make it reserved). –  sawdust Jan 26 '13 at 2:35
    
Is the dual-band router plugged in to the main router through the WAN port or LAN port? What assigns the 192.168.2.15 address? Does the main router have a WAN address? –  Tanner Jan 26 '13 at 4:03
    
The WAN port of the dual-band is connected to one of the LAN ports on the main router. The main router is assigning the 2.15 address. As sawdust pointed out, I do think DHCP is running on both, so I am going to try turning DHCP off on the dual-band router today. –  scdowney Jan 26 '13 at 14:04
    
@sawdust So I have switched off DHCP on the dual-band, but now the wifi devices cannot get an IP at all. I am not sure I set a static IP properly, but would that hinder the ability of the dual-band to "relay" the DHCP responsibilities back to the main router? Do I set the static IP for the dual-band on its own config, or the main routers config? I couldn't seem to figure out where to properly set that up. –  scdowney Jan 26 '13 at 14:44
    
And apparently I have also messed a setting up on the dual-band router now, because I can no longer access it's config page, even if I LAN connect it directly to the main computer... is my best plan to just factory reset it at this point? –  scdowney Jan 26 '13 at 15:43

2 Answers 2

What would be way easier is switching the routing off in your new router. Basically put it into Access-Point mode, this way there are no extra subnets and double routing. Depending on the router there are multiple ways to achieve this.

share|improve this answer

I'm glad you gained the insight to simply move the PC to the second, 'working' router. I would still like to explain what's going on here.

Your routers are performing NAT. I should've mentioned this in my original comment before you were sent on a wild goose chase. DHCP is not relayed over this (or at least it should not be. I cannot think of a scenario where this would be appropriate.)

Network address translation, or NAT, is essentially what turns your public IP address in to a private subnet. Computers on the outside do not "see" computers on the other side of NAT. NAT takes care of the connections, and computers, servers, etc on the other side simply see a port number and a public IP. (Someone please correct me if that's inaccurate, my understanding of NAT is purely functional.)

By plugging your second router in to the WAN port, you were telling it to take the address that is assigned to the router on the WAN side, and perform NAT to create a separate private subnet. Most consumer routers do not have the option to turn this off. Occasionally there are some settings that will shut off NAT, such as AP mode or client mode. If you provide the model of your router, someone may be able to find an emulator online and provide you with the appropriate setting.

You may also be able to connect the second router with LAN ports instead. Assign it a static IP address, turn off DHCP on the second router (the dual-band), and make sure that the default gateway on all your machines is pointing to the first router (it should be if the "main" router is handing out DHCP.) This will eliminate the network address translation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.