Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using S/PDIF and I only get sound from the right speaker plus the subwoofer.

I've checked the balance settings:

enter image description here

Adjusting #1 does nothing. Adjusting #2 affects the right speaker.

I've also tried:

  • Switch places for the speakers to make sure that both works
  • Switch the cables

Same thing. Only audio from the right speaker. So I'm quite certain that it's not a speaker problem but how windows sends the audio (or sound card problem).

Update

Here's the strange thing: My volume knob which comes with the speakers have a headphone (3,5mm) jack. If I connect my head pones to that jack I get stereo in them. Same thing if I connect my headphones to the front computer jack.

Are there a windows 8 setting which configures the soundcard to send audio as 5.1 or similar?

Update 2

I've bought a new sound card (Asus Xonar D2X). Almost the same thing. Now I only get sound from the left headphone.

I've also bought new speakers (Edifier). Same same.. :(

Update 3

If I connect my head phones to a 3,5mm souncard jack I get stereo.

enter image description here

Update 4

I've now tried with a "regular" cable from the computer to the speakers. I've made sure that a 2 speaker system is selected. Still no sound from the left speaker.

I've tried two different speaker systems and two different soundcards (the built in realtek card and my new PCIe asus one).

I've also had the same problem in windows 7 and windows 8.

Hence the only thing left is the mother board, right? But before I accept an answer how could the motherboard affect the sound in such way?

Update 5

Ubuntu and Fedora gives me the same errors when I try to boot them (burned a live cd for both):

Something like:

GPU Lockup switching to fbcon
[...]
PFIFO playlist update failed

So that makes it a bit hard to try the sound using linux.

Update 6

I tried the new speakers with my laptop and got the same result. So I tried my old speakers with the laptop and both works (seems like one of the speaker cords were loose, I had to wiggle it. I blame my son for that ;)).

The new speakers have red/white connector. And I tried to switch them resulting in the same speaker only getting sound. So the computer seems to send stereo all right.

Next test was to switch the speaker cables on from the bass unit. Then the sound shifted to the other speaker. So it seems like the hardware in the bass or the speaker connector is broke?

So all of this just seems like a circumstantial mess :( First that the old left speaker got played around with by my son (resulting in me buying new speakers which didn't work either). And then a new soundcard. Guess I'll go and return the new speakers then.

Thank you all for helping me, and sorry for not trying harder in the first place.

Update 7

Heh. I still get problems. Everything have now been switched and I find it hard to believe that my third pair of speakers are broken too.

share|improve this question
2  
I think you should try a Linux live CD or live USB to verify whether it's software related. If you get proper sound in the Linux environment, with all the other things you tried, I would look at reinstalling Windows. –  mxl_ Feb 5 '13 at 20:52
    
I've already switched from win7 to win8. Same problem –  jgauffin Feb 5 '13 at 21:44
    
This is abnormal behavior. Try sfc /scannow to verify system integrity. –  harrymc Feb 6 '13 at 8:25
1  
When you say you switched from Windows 7 to 8, did you format the disk and clean install, or did you do an in-place upgrade? And are you saying the problem was present in Windows 7 originally? –  mxl_ Feb 6 '13 at 10:06
2  
Because this absolutely rules out it being a software setting. My thought is the same as Enigmas, wiggle the TOSLINK plug where it's connected to the motherboard, or grip it and see if you can't push it a little further in, sometimes they get wedged 9/10ths of the way in, picking up an incomplete signal. Check the point where the optical goes into your receiving unit/subwoofer in a similar way. Check both connection points of the cable going between subwoofer and problem speaker. If this was checked very thoroughly but did not help, swap the cable between subwoofer and problem speaker. –  mxl_ Feb 6 '13 at 11:31

6 Answers 6

up vote 2 down vote accepted
+100

Root cause : The cable for the LHS speaker is broken. It might have broken at either of the ends.

Try connecting your speaker to another audio output - ipod etc. If it does not work, then this diagnosis is right.

share|improve this answer
    
This isn't the right answer for me, I only get sound out of my right speaker on two different jacks on two different devices. –  Mark Kramer Feb 18 at 3:32

There is a setting that changes the output format of the audio. It is my suspicion that the left channel of your audio is being routed to your subwoofer. Windows may not be autodetecting your speaker configuration properly and might be sending a stereo signal to your speakers incorrectly.

Try right-clicking the sound device and clicking Configure Speakers, instead of double-clicking to get to Properties.

A configuration wizard should appear, starting at the "Speaker Setup" step. It should let you change the output format of the sound. Choose the one corresponding to your setup. For instance, this is what I see when I do it on my laptop:

enter image description here

Also, make sure that you are hooking up your cables properly behind your computer! I have a 5.1 audio system hooked up to my computer at home, myself. My motherboard supports up to 7.1 surround, and so not all of the audio output ports are hooked up. Make sure the color-coding on the speaker cables and your back panel connectors match. In my case, the orange and pink-labeled inputs are very similar and, if you aren't careful, can be easily mixed up.

share|improve this answer
    
this, while useful and one of his sub-questions, does not help solve his underlying problem. –  Enigma Feb 5 '13 at 17:55
1  
@Enigma It is my opinion that Windows is sending a stereo audio signal to his speakers, hence getting sound from two of his speakers. For whatever reason, I believe the left channel is being routed to his subwoofer. He said he believes it's not a hardware issue after trying various configurations, which is why I mentioned this solution. Perhaps Windows isn't properly detecting his speaker setup and so he has to manually tell it to send a 5.1 channel signal. –  Ben Richards Feb 5 '13 at 18:04
1  
sure that's plausible. +1 - might want to add that to your answer? fyi its a 2.1 set up (left, right, and bass) the 5.1 reference was more for speculation and as an example of alternative selections i believe. –  Enigma Feb 5 '13 at 18:07
    
@Enigma Edited. Also made mention of double-checking the cables behind the computer, as I realized that it might be related, and is a good thing to check. –  Ben Richards Feb 5 '13 at 18:10
    
definitely good to check the cables. I've run into a probably now rare case where none of the colors for my 5.1 matched up to the port colors on my motherboard. took some trial and error. –  Enigma Feb 5 '13 at 18:12

Have you tried disabling the mobo soundcard from BIOS and running strictly off of your PCIe one?

Are you getting full range sound from your subwoofer instead of only low frequencies? Can you hear voice and system sounds, or is it playing correctly?

Since your getting stereo from the 3.5mm jacks, sound is being processed correctly into analog, which is actually one degree further than using the SPDIF which is full digital.

Have you tried changing your SPDIF output mode?

Does your speaker setup have different options for surround output modes? Dolby, Quadraphonic, etc....

What model of edifier speakers are you using?

share|improve this answer

It's almost definitely the jack on the back of your computer that the speakers are plugged into or the motherboard itself (either drivers/hardware/bios). I have a 5.1 system that has had similar problems and I narrowed it down to the motherboard jacks. You can certainly try jiggling them but your ultimate solution is probably to get a nice sound card.

Depending on where/how the volume knob extension is hooked up, it is probably consistent with what I am saying. ie, if the volume knob comes from the right speaker which works, the knob's jack would need to be able to receive full stereo through it and that's why you get full stereo with your headphones.

For any playback device, you can go into the sound properties and configure it to be a range of things but it is often limited by what it's detected capability is.

Also, given that your stereo 2.1 set up probably has 1 main audio plug that goes into the back of the computer, switching how the individual speakers are hooked up changes nothing about how the motherboard is transmitting the audio signal. ie, still will only send to the same speaker it has its connection with.

Wiggling the rear jack and pulling it out a little bit will help troubleshoot this while playing a stereo music file.

It could, alternatively, be the connection point on the back of your 2.1 sound system from your computer where your sound system receives the signal transmitted from the motherboard.


It is still likely the S/PDIF port on your motherboard or how the motherboard handles the S/PDIF interface in general (ie, a sound card using S/PDIF would still need to go through the motherboard). The audio jack on the front of your PC is interfaced differently so it is not relevant.

The only thing to try in that case is to try it out on a different motherboard. (I had a motherboard from asus where the audio chip crapped out and wouldn't play standard 3.5mm audio correctly - I was effectively getting mono all the time instead of stereo).

Also, try your sound card on another motherboard to rule that out.

If it is not the actual connection jack on the motherboard, it may have to do with your OS but that's not as likely as it being the motherboard at this point.

It would be good to try a free Linux platform like Ubuntu nevertheless.

All audio getting processed goes through the motherboard regardless of where/how its connected. It is the key juncture and if you rule out everything else around it, the motherboard itself must be what is wrong.

You may have some luck tweaking bios settings or updating the motherboard bios but if that doesn't work, I'd just go grab a drop in motherboard from a different manufacturer that fits your current spec.

share|improve this answer
    
I'm using optical SPDIF. I found no way to configure it (to setup the amount of speakers) –  jgauffin Feb 5 '13 at 19:31
    
Look at the answer here: superuser.com/q/215758/160458 –  Enigma Feb 5 '13 at 19:36
    
Also update drivers to latest if they are not already. Sometimes simply re-installing drivers helps reset or clear some bad config/data. –  Enigma Feb 5 '13 at 19:43
    
I've installed the latest drivers –  jgauffin Feb 5 '13 at 19:58
    
Check edits below hr line. –  Enigma Feb 6 '13 at 17:56

You had this problem with 2 different sound cards and 2 different speakers so it seems it is because of OS or motherboard.

MS changed how your PC is shut down in , in other words it is just like hibernation now. Therefore when you face with hardware related problem, you have to use restart since shutting down will not solve it.

Note that older Windows had problem with restarting such as when you have a problem with a driver, it may exist after resetting but shutting down since it was not like hibernation.

As a result, firstly restart your PC. When you see booting screen, which says press F1 or other keys for entering boot up setting, press turn off button on your PC. Then wait about 30 seconds and turn on your PC.

If your problem still exist and everything is ok in the device manager, your motherboard could be the problem.

share|improve this answer

If only one speaker works in Win 8.1:

  • click the little up arrow at the right end of the bottom toolbar of the retro desktop screen with traditional icons (not the new apps screen)
  • click the speaker icon, which opens Realtek HD Audio Manager
  • choose Speakers at top
  • click Speaker Config
  • choose Stereo
  • click blue Auto Test arrow
  • both speakers should now be audible in the test, worked for me.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.