Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I switched from Linux to Windows. And I copied some private files (include folders) from ext file system to NTFS file system partition (operated on Linux). Then I logged on Windows as user A (for example), and found those file I copied belonged to Everyone Group with state "shared". I wonder how to transfer those files' ownership to user A and disable the shared state.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

With sufficient rights on the win7 site you can take ownership of the files.

There are several ways to to this, the graphical way is to right click on the folder or file(s), select properties, tab security, [Advanced]. tab Owner and then [Edit].

enter image description here

A non graphical way is via a command prompt (either an elevated cmd.exe or a modern powershell). To take ownership use takeown. To edit rights you can use icacls.

enter image description here

share|improve this answer
    
Oh, the graphical way is impossible for me ,for I already have the ownship of folders (not files). With command takeown I did get the ownship, but Everyone Group still owns my files. What should I do to remove it? –  Noverull Jan 27 '13 at 5:55
    
Once you have ownership you should be allowed to change permissions. (For that use tab [security rather than tab [Owner]). –  Hennes Jan 27 '13 at 9:17
    
Now I have two problem. One "Is there a way to change permissions in one run?" Two "Just now I checked my files and found in fact I did not take the ownship, what's wrong? the command I used was 'takeown /F [My Folder] /R /D Y' or 'takeown /S [Computer Name] /U [User Name] /F [My Folder] /R /D Y' under Administrator. The output messages showed OK.". –  Noverull Jan 27 '13 at 9:59
    
Why the /s, which specifies a remote system to connect to? What is the resulting output of takeown /f testfile and takeown /f DirectryToRecover /R ? ( When I run D:\>takeown -f "Untitled 1.odt" then I get this answer on the next line: SUCCESS: The file (or folder): "D:\Untitled 1.odt" now owned by user "Core\hennes"). –  Hennes Jan 27 '13 at 10:51
    
When I runned Powershell under Administrator, I thougt if I execute 'takeown' without assigning a user account, it'll take Admin for default. '/U' shall go with '/S', so I added it. I tried again without '/S' and found it's not the case (So, it's my fault, sorry :( ). Then I tried on a file and found 'takeown' did still not work. The output messages are the same to yours :(Such as )'SUCCESS: The file (or folder): "C:\Users[myuser]\Blender\blend\animation\CtrlObject.blend" now owned by user "[computername\username"' –  Noverull Jan 27 '13 at 11:44

From elevated powershell

takeown /F "C:\SomeFolder" /R /D Y
share|improve this answer
    
Yeah~ With /D Y I did get the ownship, but it is still "shared"... How to remove Everyone Group? –  Noverull Jan 27 '13 at 5:49
    
I should have checked it more carefully. In fact I did not take the ownship with the command even if Powershell runned under Administrator. The output messages showed everything went well. –  Noverull Jan 27 '13 at 9:55
    
I should have cheked it more and more carefully. In fact, I did take the ownership but had no permission to write or read a file, and I did not realize that. Now, everything goes well. –  Noverull Feb 1 '13 at 16:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.