Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There are already a few related questions - but unfortunately, I cannot make comments, so I have to create a new question. So, first ... the related questions / answers are:

I've tried everything that's described in those questions, and also followed one thing I found interesting in the answer to "Another installation is in progress":

I have seen it before where the .NET Runtime Optimization Service is constantly firing off ngen.exe using the installer service to generate optimized .net assemblies and never allows the installer to use anything else. You can try stopping that service to see if it makes a difference.

So ... this is exactly what I'm seeing. So I followed advice given in:

What is mscorsvw.exe? how to disable it from running

This all happened after upgrading SQL Server 2012 Express to SQL Server 2012 Enterprise. And interestingly, when I execute:

ngen.exe executequeueditems

I'm getting quite a few errors, e.g.:

Failed to load dependency SqlWorkbench.Interfaces of assembly Microsoft.SqlServer.Management.UserSettings, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91 because of the following error : The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

When I run the command again, eventually, I'm getting:

All compilation targets are up to date.

But .NET Runtime Optimization Service and Windows Installer are still consuming my CPU ... and I'm still not able to install Team Foundation Server on that machine.

I can kill ".NET Runtime Optimization Service" - but a new one will be spawned a few seconds later.

Another thing I've noticed and that puzzled me a little (most likely not related - but just to be sure to have given all information): In the registry path

*HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\PnpResources\‌​Registry\HKLM\Software\Microsoft\Windows\CurrentVersion\RunOnce*

I see an entry (even after rebooting a few times): ASYNCMAC, Owners netrasa.inf

Should that really be there?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.