Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Surprisingly I can't find much about this. Basically, in Outlook 2013 (or Windows Live Mail 2012 too), if I have more than one account (an IMAP and exchange, in my case), I don't always get new mail notifications for the IMAP account. Exchange works fine (i.e., new mail comes in, I get an alert). I'm talking specifically about IMAP and the "push" functionality.

The only way I seem to get alerts for IMAP alerts is if I leave the inbox for the IMAP account selected. From then on, I get alerts for my IMAP account, even when outlook is minimized.

The only program that seems to consistently give me new mail alerts if the built-in Windows 8 Mail app. The only thing I don't like about that is I don't get an email notification in the task bar (in case I miss the alert). My goal is to use Outlook.

Is there something I can do in Outlook to more reliably get new email notifications for IMAP accounts? I've also tried a Gmail account and have the same behavior, even on multiple machines. Thanks.

share|improve this question
    
Look at that. Two years have gone by and no change in the status of this issue. I'm having the EXACT same bug (on my PC and tablet). I've got multiple IMAP accounts and they're only updated if I have one selected. The built-in mail application seems to work, so I guess Microsoft is telling us that it's time to leave Outlook behind. –  DRAirey1 Mar 25 at 17:40

2 Answers 2

I would create a rule that displays a desktop alert when mail is received. I don't think you're issue is w/ IMAP receiving email, but with Outlook notifying you that mail is being received inside that inbox.

You can create rules that display desktop alerts (The default desktop alert is just a rule itself), only from certain people/groups or sent to certain people (like me@hotmail.com so I only get desktop alerts when people send to my hotmail address, for example.)

Update Due To Comments

In that case, reduce your send/receive time from the default down to 1 minute (Under Options->Advanced Send/Receive), mine was 30 minutes and it made all the difference in the world.

enter image description here

share|improve this answer
    
The issue is that, I only ever get email pulled into my inbox if I click on the inbox folder (for the IMAP account). It will then sync and display an alert. I don't want to have to click this folder in order to have outlook sync and alert me of email. –  Ryan Peters Feb 1 '13 at 18:36

Microsoft is not going to fix this one, so I see three options:

  1. Wait for Office 2016 and hope they fix it.
  2. Switch all your email accounts to Exchange and then Outlook will work just great.
  3. Abandon Outlook 2013 and use the built-in Mail application that comes with Windows 8.1.

The built-in application is raw, but it does the job. I beat myself up for a day looking for a solution for Outlook 2013. It's very clear after scouring the web that IMAP is broken in Outlook 2013 and there's no will on the part of Redmond to fix it. The free application really isn't too bad if you just focus on what you need email for.

share|improve this answer
    
I've been using emClient since that time and love it. Great support for IMAP. –  Ryan Peters Mar 26 at 0:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.