Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

From some time I have had an Radeon HD 4650 AGP graphic card. I wanted to start mining on my GPU, as it brings more BTC, but miners are not able to find my card.

I've checked it with GPU Caps Viewer, and it shows that it does not support OpenCL. Is it true? If it normally supports it, how can I make it work?

share|improve this question
    
Have you made sure you have the latest graphics drivers? –  Marcus Chan Jan 28 '13 at 2:17
    
Yes, I have the newest drivers possible. @magicandre1981 Is there a possibility to get some kind of modded drivers that would make OpenCL work on 4650 ? –  CamIce Jan 28 '13 at 13:38
    
@CamIce I doubt that this is possible. –  magicandre1981 Jan 29 '13 at 5:40
    
@magicandre1981 Well, thank you, then, my friend :) –  CamIce Jan 30 '13 at 15:01

2 Answers 2

up vote 3 down vote accepted

I happen to own both HD 4650 and 4670 AGP cards and have already verified that they do indeed support OpenCL 1.0 at least in a Windows environment (tested on Windows XP and Windows 7 32 bit).

I did notice, however, that with most Catalyst versions they are not recognized as OpenCL devices, so you might have to play around with the driver/application version. Mainly I would suggest using Catalyst version 11.9 AGP hotfix.

I've tested performance of the cards in oclhashcat benchmark and here are the results for MD5 brute forcing on each cards:

  • HD4650 AGP: 265.6 Mhash/s @ 600 MHz
  • HD4670 AGP: 329.1 Mhash/s @ 750 MHz

One more thing to keep in mind is that for OpenCL to work you need a CPU with SSE2 or greater. On both of my AGP legacy machines I'm running Pentium 4 prescott.

share|improve this answer
    
Thanks! Unfortably, I have newly switched to Ubuntu, but I will surely find a way to get something out of the graphic card :) Do you think it would work with Intel Pentium 4 Northwood? Mine CPU is pretty close "brothers" with yours, so it should work, am I right? –  CamIce Mar 31 '13 at 23:53

According to AMD, you need at least a Radeon HD5400.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.