Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to copy photos from my camera's memory card using Windows photo copy wizard, however I'm not connecting the camera directly (I lost the cable) rather I'm inserting the camera's SD memory card into the memory card's slot. Windows (Vista) recognizes the memory card and I can explore the photos but it doesn't automatically launch the "Device connected, what do you want to do" wizard. How do I manually launch the photo copy wizard?

share|improve this question
up vote 3 down vote accepted

I guess you would have an option called AutoPlay when you do right-clicking on the memory card. Ths will launch the autoply dialog, that usually comes popping.

Sometimes, autplay may vanish. See this link for more details on how to get it back.

share|improve this answer
Nope, no such option :o( – Motti Oct 12 '09 at 12:21
Oh! :( Thats seriously a problem. Check my edited answer. that link might help you. – vpram86 Oct 12 '09 at 12:26

I know this isn't answering your question as stated, but the simplest way to get the photos off the memory card is to open Windows Explorer and browse to the memory card "disk". There'll be a folder called DCIM (or something similar), keep expanding this until you find a folder containing jpg files and just copy them to your PC's hard drive as you would any other file.

Obviously this won't allow you to perform actions on each file such as renaming, setting EXIF (property) data etc.

share|improve this answer
This doesn't provide the renaming option which is why I want the wizard in the first place. – Motti Oct 12 '09 at 12:46
@Motti - OK, but you didn't mention that in your question. – ChrisF Oct 12 '09 at 13:13

I'm using XP professional, and if you go to My Computer, and right click on the drive you want, select Properties and click on Auto Play, select the type of file you have (ie photos, video etc.) and then select an action it should show as "copy pictures etc." and if you select that, then "apply" at the bottom, it should show up the next time you plug it in. Hope this helps.

share|improve this answer
This adds nothing to the accepted answer. – Chenmunka Sep 30 '15 at 9:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .