Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When a user logs onto a computer the "Language for non-Unicode programs" changes to US, now i change it and apply to all profiles, but when he gets up and moves to another computer the same thing happens again and i have to change it again

Is there anyway i can set this so it stays, bearing in mind his profile is no different to the other 200 profiles we use and they work fine

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The Language for non-Unicode programs setting is a system-wide setting and not a per-user setting. In fact the description of the setting is

This system setting enables non-Unicode programs to display menus and dialogs in their native language. It does not affect Unicode programs, but it does apply to all users of this computer.

If this setting is truely changing when they log in they have to be an administrator first. System wide settings cannot be changed by normal users (hacking excluded of course). If the user is an administrator I would check their startup programs and logon scripts and see if something is overwriting the registry key with the value for English (United States).

Lastly, changing this setting requires a reboot of the machine, so if it had the proper language previously set and changed to English after the user logged in, it wouldn't take effect until the machine was rebooted.

share|improve this answer
    
All i can tell you is, whenever this person logs onto a computer, they are instantly changed to US format, when anyone else has been using this computer it works fine –  admintech Oct 12 '09 at 14:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.