Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an XP machine sharing a folder on my home network. I am accessing this folder from a Win8 computer on the same network. For the most part, this works. But there are a few cases where trying to access a subfolder brings up an error saying that I do not have access to the subfolder. As far as I know, these inaccessible subfolders are identical to the accessible ones except for one thing: they are the TARGET for a junction living in another folder. Would this make a difference? Note that all folders have the same owner on the XP machine, and the only sharing I have done is to right-click on the root d:\sharedFolder, click "Sharing and Security", and check "Share this folder on the network" and "Allow network users to change my files".

Here is an illustration of the setup:

c:\someJunctionA  --> d:\sharedFolder\folderA
c:\someJunctionB  --> d:\sharedFolder\folderB

d:\sharedFolder
    \folderA      //  inaccessible from my Win8 machine
    \folderB      //    accessible from my Win8 machine
    \folderC      //  inaccessible from my Win8 machine
    \folderD      //    accessible from my Win8 machine
share|improve this question

1 Answer 1

up vote 2 down vote accepted

The most common mistake people make which causes problems with sharing in Windows is dealing with permissions. There are two sets of permissions to manage when dealing with sharing.

First is the share permission. Most people set this correctly, as it is the set of permissions that shows when setting up a share.

Secondly, is the file and folder permissions. Even if the share allows you to access the file, if the user doesnt have permission at the file level, they will be denied access. These permissions are more restrictive and take precedence over share permissions.

The first step would be to examine the share permissions and the file/folder security of the shares that do work and the shares that dont. You will probably see a difference and that is most likely the problem preventing you from accessing the data on a remote machine.

share|improve this answer
    
That was the issue. Thanks! –  loneboat Jan 28 '13 at 6:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.