Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed windows 7 Pro x64 on a 128 GB Adata SX300 SSD yesterday (clean install after full format, SSD is brand new) and installed a bunch of programs and all available updates from windows update. Then when it tried to install SP1 for Visual Studio 2010, it failed due to lack of free space. Less than an hour before that windows showed I have ~60 GB free of the 119 GB on the drive, and now it shows ~2 GB is free.

I selected every folder and file (with hidden and system files showing) in the root of the drive and checked their size in their properties, it says they use 64.3 GB. I also checked it with Total Commander, it says they take up 71 477 304k and there is 2 764 476k free of 125 032 444k (I guess it asks the free space from windows instead of calculating it).

So it doesn't add up.

This is what I've tried to no avail:

  • Run checkdisk
  • Run defrag
  • Run windows' disk cleaner (it found 2 gigs of temp files but nothing else big. I deleted them and the remaining space stayed about the same (!))
  • Check for viruses with NOD32
  • Check for spyware with Spybot S&D

Extra info: I've relinked my documents folder to another drive, but it's only 25 GB, so even if windows mistakenly counted that in, it doesn't add up.

Now I'm all out of ideas. What could cause this?

Thanks for your help.

Update: while I was typing this, windows reconsidered its opinion and now it shows 5,5 GB is free.

share|improve this question
3  
1) Running defrag will not help. Rather it hurts. 2) How many shadow copies and how many restore points are around? 3) There are some know problems with actual free space and calculated free space if links are used (and a lot of space is (not) used by links in the winsxs folder). –  Hennes Jan 28 '13 at 13:15
    
I checked shadows with vssadmin list shadowstorage and vssadmin list shadows but they didn't return anything. I deleted the restore points with disk cleanup but it freed only around 1 GB. Meanwhile the free space is slowly growing, now it is almost 7 GBs... Is there any way to see if links are causing the problem, or fix them somehow? Thanks –  KáGé Jan 28 '13 at 13:47
    
To get the real size of a folder use ctts.exe from heise.de/software/download/cttruesize/50272 (See social.technet.microsoft.com/Forums/eu/w7itproperf/thread/… ) –  Hennes Jan 28 '13 at 13:53
    
Here's what I've got: link Windows says 114 GB is used. Total commander says only 66 GB. –  KáGé Jan 28 '13 at 14:10
    
@KáGé - how much RAM do you have on your system? This will be relevent for page file size. Or have you changed Page file size already? –  Carl B Jan 29 '13 at 21:02
show 1 more comment

1 Answer

up vote 2 down vote accepted

So, I gave up on this, but today I couldn't install some SDK for the lack of space and went to reinvestigate.

It turned out, that by default, I didn't have access rights to Windows/Temp, which means it was excluded from space computation.

It also turned out, that Windows/Temp contained 60 GiB (!) of junk, that Windows seems to have forgotten about, probably because I changed the system temp dir to one on another drive.

Now all is well.

Thanks for everyone's help.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.