Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Vista 64Bit with VMWare workstation(the latest release of everything).

If by chance I lose my DSL connection, no matter what I do I can't seem to get any of the VM's to connect back to the internet, without shutting everything down and rebooting the whole physical machine - (the desktop, reconnects just fine). I often have 3-4 VM's running (NT, NT Server, XP) with multiple apps open in each, plus many apps running in my regular desktop (i.e. not within a VM). Needless to say, its is timeconsuming and a pain-in-the-neck to shut everything down and then reboot and reset all my apps....

Even shutting down all the VM's and shutting down VMWare doesn't solve the problem, only a full-system reboot.

Any suggestions? This seems to be a new problem, perhaps since I upgraded to the latest VMWare workstation release - I am not 100% positive, but I 95% sure that up until a 6 weeks ago or so, if the DSL connection was lost, everything would reconnect when it came back on...

Thanks for any suggestions.

Edit: Additional puzzling information is that I can still access other machines on the network from this machine, i.e. map a network drive back to the host and read/write files - just won't see or talk to the internet from any VM.

share|improve this question
up vote 1 down vote accepted

I have had this a few times, I go to removable devices and just disconnect the network card, wait for the VM to detect the "cable" is out, then reconnect.

This always does the job for me.

share|improve this answer

I use a small script that disable and re-enable the network card. Script is as follows:

devcon.exe disable *DEV_2000*
devcon.exe enable *DEV_2000*

The utility devcon.exe can be downloaded from http://support.microsoft.com/kb/311272, and the network card id can be found in the Device Manager, properties for the network card in the tab called details. It will look like this:

PCI\VEN_1022&DEV_2000&SUBSYS_20001022&REV_10\4&47B7341&0&0888

Then its just a matter of clicking an icon to run the script, and the network card should work right after that.

share|improve this answer

Try disabling the virtual NIC and re-enabling it while the VM is still running. If you aren't using static addressing, release and renew your IP address.

share|improve this answer
    
I have tried all that and still no luck. – EJB Oct 12 '09 at 16:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .