Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I set up a web server on a Raspberry Pi (running a Debian package) and everything that I need is set up, and I've uploaded my website via FileZilla. Now I can connect to the server via the static IP address within my local network, but when testing it via just ping, I get the message "Packet lost (100%)".

I've done some research and tried a full power cycle on my router, and I still get this message. I am fairly new to web hosting and don't know much about it, but how do I get rid of this 100% packet loss?

I've set up my Domain name with and the domain (if you want to test it) is . I've set it up with the DNS so that it points to my IP address.

And also, I asked a question on Yahoo Answers and I was told to port forward my local IP and use TCP/80. Is this the right configuration? Is this why I'm getting 100% packet loss?

If not, someone please tell me what to do! Thankyou so much if you help!

share|improve this question
Are you saying that everything works from your local network, but it doesn't work when you try to access your Pi remotely over the Internet? – HeatfanJohn Jan 28 '13 at 16:23
Yes, well, not really, I don't know how to test it remotely over the internet. If i enter the domain, it takes me to my router page. – ReallyGoodPie Jan 28 '13 at 16:27
If you're taken to your router page, you still need to set up port forwarding from your router to your Raspberry Pi device. – slhck Jan 28 '13 at 16:41
I managed to test it via Nibbler and it seems to be working fine. – ReallyGoodPie Jan 28 '13 at 16:53
@ReallyGoodPie - If you are getting the configuration page, then the router is NOT configured the correct way, to forward the packets to your Raspberry Pi – Ramhound Jan 28 '13 at 17:26
up vote 2 down vote accepted

Ping is an ICMP echo request. This is blocked by firewalls by default. It's likely the firewall in Debian or your router is set to block ICMP echo requests. You can test which by doing tracert from a windows box using CMD, to the IP or name you are pinging. The response will stop at the device causing the problem. You can also use traceroute from the command line of a linux box.

Ping does not travel on port 80, that is reserved for HTTP traffic.

share|improve this answer
Cheers, this is not affecting my website is it? Can it still be accessed or do i have to enable ICMP echo requests? – ReallyGoodPie Jan 28 '13 at 16:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .