Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 machine, in which I've installed the Microsoft Virtual PC, so that I can have Windows XP on the Win7 machine. (I need it for some legacy development.) I've renamted the VPC and then rebooted. Next I tried to join the Active Directory domain (Windows 2003 R2 Server based), but I got an error that says:

"A domain controller for the domain MYDOMAIN could not be contacted. The following error occurred when DNS was querieed for the sewrvice location (SRV) resource record used to locate a domain controller for domain MYDOMAIN: The error was: 'DNS name does not exist' (error code 0x0000232B RCODE_NAME_ERROR)"

I know we have an DNS server, so I'm not sure what the problem is.

share|improve this question
    
Is the Windows XP VM on the same network as the host and the Domain Controller? –  Dave M Jan 28 '13 at 18:30
    
I would assume that the Windows XP VM is on the same network as the host. How could they be different? –  Rod Jan 30 '13 at 15:19
add comment

1 Answer

Can you ping your domain server from w/in the VPC? try pinging the fully qualified domain name, so if the server is test and your domain is example.com, you want to ping test.example.com and make sure you see an IP address in return, and that there is some activity there. If that works, try joining the domain using the fqdn instead.

Update for comment

It's possible then one or both of the following:

1)The server isn't responding to ping requests, but is up and running for you to join a machine. If that's the case, trying to join the domain using the fully qualified domain name should work.

2)The server is down or otherwise unconnected to the network. 'Down' in this case means not responding to domain requests, so it could be crashed, powered off, unplugged, etc. This is where you get the person who manages the domain server involved.

share|improve this answer
    
I cannot ping it, even when I fully qualify it. I do get the correct IP address, but the request times out. –  Rod Jan 28 '13 at 19:40
    
I just tried joining the domain, and fully qualifying it (using your example, test.example.com), but I got the following error. "The network path was not found." –  Rod Jan 30 '13 at 15:18
    
Yeah so likely that server is down for some reason similar to above, the client sounds fine, the only other thing is to make sure the domain controller and the client are on the same network. –  BigHomie Jan 30 '13 at 15:22
    
How do I do that? I'm ignorant enough to think that since the host PC is on the network, the VM should also be on the network. –  Rod Feb 1 '13 at 22:58
    
The easiest way is to compare the IP address of the VM with the IP address of the domain controller. on your VM, run ipconfig /all in a cmd prompt, and also note the subnet. In general, the first couple of octets should be the same for both IP addresses. –  BigHomie Feb 2 '13 at 2:08
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.