Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Suddenly my USB Flash Drive (8gb Corsaire Voyager) is suddenly read-only, and I'm not sure why.

There is no "read-only" switch on the drive. All of the data is still there. But nothing can be written to it anymore. There are 2gb free on the drive. The OS is Windows7 Pro x64. It wasn't this way yesterday.

In FreeCommander, if I try to create a new folder on the drive, it tells me the drive is write-protected.

I plugged it into a different computer and it is read-only there, too.

What could cause that, and how can I get it back to read/write mode like it ought to be? I know I can fix it by reformatting it, but I don't want to do it that way.

I have found several solutions to do this, but haven't solved it yet:

  • Safely Eject Flash Drive
  • Make a registry edit (the key doesn't exist, however)
  • Add the registry key (that didn't exist) and set the value to 0 (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies set WriteProtect to 0)
  • Reassign the drive letter
  • "Scan and Fix" (check disk dialogue appears when you plug it in) - write-protection prevents this, however.
share|improve this question
If you right click on the drive and go to security tab, is "allow" checked in the permissions field for "Everyone"? – Carl B Jan 28 '13 at 20:46
There is no "security" tab in the "properties" dialogue like there is on a regular drive. I think something is wrong with the hardware. – bgmCoder Jan 28 '13 at 21:34
@BGM-I should have waited for your reply as I answered as if you could get to the security tab. – Carl B Jan 28 '13 at 21:40

There are a lot of possible causes of this one. has a number of solutions like changing the drive letter and, if nothing else works, low-level formatting the drive.

share|improve this answer

What could cause that?

This can happen by pulling the drive without using "Safely remove Hardware and eject".

how can I get it back to read/write mode like it ought to be?

A first check would be to ensure that the permissions are set to allow in each catagory. If it is blank, this could cause an issue for writint to the drive. To check do the following:

You would right click on the drive and select properties. Click on the Security tab and click on Edit

USB 1 Under each Title (Everyone, System) be sure the first box (Full control) is checked.

Click OK. If permissions were the issue, this would resolve it. Usb 2

share|improve this answer
Uh, I did say there was no "security tab"... – bgmCoder Jan 28 '13 at 21:44
I answered before you stated that. – Carl B Jan 28 '13 at 21:47
Oh, sorry, it wasn't showing. – bgmCoder Jan 28 '13 at 21:48
Actually, I think we posted at the same time. – bgmCoder Jan 28 '13 at 22:00
up vote 0 down vote accepted

The drive is going bad. I've seen this happen to USB flash drives before - they are only temporarily good for storage, and you have to keep them backed up.

To confirm that the drive is bad, whilst copying files from the drive I see that it says certain files that are queued for copying do not exist.

Also, it is marked with write-protection, even though there are no registry entries causing that to be so.

A DOS prompt cannot be had!

Trying to copy files from the drive is nearly impossible.

Time to buy a new flash drive.

share|improve this answer

If something is not working on one of my flash drives then I usually use GParted or something similar (GParted is Linux only, MiniTool Partition Wizard seems good for Windows.) to recreate the MBR and erase all partitions, then I create a new FAT32 partition on it and it usually works again. If your USB is failing due to age, then nothing can help you. Solid state drives (including USB drives) can only function after so many read/writes.

Also, remember to always back up data before messing with the drive's partitions.

share|improve this answer

I had the same issue, but I tried changing the allocation unit size to default and it worked.

enter image description here

share|improve this answer
A key word here is "suddenly". The allocation unit size doesn't suddenly change on its own. – fixer1234 Apr 17 at 19:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .