Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Apologies if the title doesn't quite make sense, I really have no idea what's going on here.

I have a 2-yr-old Lenovo X220 laptop with dual-boot Windows and Ubuntu which I often connect to a ~4-yr-old external 24" Samsung Syncmaster monitor (native resolution 1920x1200). Recently I wiped the Ubuntu partition and re-installed a more recent version (12.04, previously 10.10). Prior to this upgrade, both Ubuntu and Windows would automatically switch to 1920x1200 when attached to the monitor and the position, size etc of the image looked great. I vaguely remember tuning the monitor's V-pos/H-pos etc when I first got it but nothing radical. The laptop attaches to the monitor via VGA analog since it doesn't have any other video port.

After upgrading Ubuntu, when I went to Display settings under Ubuntu and selected 1920x1200, the image was way off -- the desktop is stretched off both sides of the screen but not evenly -- there was more hidden on the left side. I tried resetting the monitor to factory settings and toggling the "Image Size" setting between "Wide" and "Auto" (the latter is meant to detect e.g. 4:3 resolution VGA signal and display it as a square in the middle of the screen instead of stretched). When set to "Auto" the image actually does appear square even when set to 1920x1200 (which is wrong) but the hidden regions are still not visible. Hitting the "auto-adjust" button on the monitor doesn't improve things noticeably.

Now here's the weird part: essentially the same problem presents when I boot Windows, to which I had not made any changes. I also confirmed by plugging in a different laptop that the monitor is still capable of showing a correct 1920x1200 fullscreen image: hitting "auto-adjust" with the other laptop gives a perfectly framed image.

Furthermore, under either Windows or Ubuntu I can switch the resolution to e.g. 1650x1050 and get a perfect display. It's only 1920x1200 that's screwed up, on both OSes but only on this one laptop.

What the #%^$ is going on, and how can I fix it? How does this specific laptop and monitor "remember" to do the wrong thing even between OSes? I've tried booting from a liveUSB (Ubuntu) and the same problem presents: 1920x1200 is screwed up, other resolutions are fine.

share|improve this question
1  
Strange... Have you checked the BIOS? Could something be set there? –  terdon Jan 28 '13 at 21:25
    
there's nothing relevant in the BIOS (I did look). Wouldn't make sense anyhow since everything worked fine before the upgrade and I didn't touch the BIOS. –  Joe Jan 29 '13 at 2:39
    
Nothing at all in what you describe makes sense, so I thought it worth a shot :). –  terdon Jan 29 '13 at 3:03
    
Does manually editing the monitor timing settings make 1920x1200 appear correctly? –  Marcus Chan Jan 29 '13 at 3:51
    
re: manually editing the monitor timing settings -- I don't see anything to do with "timing". I see "Coarse: 2240" "Fine: 0" Sharpness: 50". I don't know what these mean but I've fiddled with them and they seem to subtly change the image but not fix it. H-position and V-position don't help as it's the size/aspect, not the position. There doesn't seem to be an "H-stretch" or "V-stretch". –  Joe Jan 30 '13 at 4:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.