Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a folder with my pictures on a network drive. I would like that folder in the pictures library in windows 8. It wouldn't let me add it since the network drive isn't indexed. Windows help said this could be accomplished by creating a folder and adding it to the library, then deleting the folder and then running a series of commands to create a "symbolic link". I've created and deleted the folder and added that to the library. The location is c:\FILESERVER\Pictures. The location of the pictures folder I've been trying to add is \FILESERVER\DATA\My Documents\Pictures.

To create the symbolic link I've been using mklink /d "c:\FILESERVER\Pictures" "\FILESERVER\DATA\My Documents\Pictures".

This has been returning an error stating that the path couldn't be found. Any thoughts?

Update: Seems to be a real issue that others have noticed as well, I still haven't been able to get it working even with much help from STTR. I was able to add the pictures to the library while on the server by modifying the location of the My pictures folder that is in the library already but it remains unindexed and thus unusable by the picture viewer app etc. Hopefully a service pack or patch will fix this soon.

share|improve this question
    
fsutil behavior query SymlinkEvaluation - may be symbolic link disabled? –  STTR Jan 29 '13 at 4:34
    
If symbolic link is disabled how could I go about re-enabling it? Not sure I understood the first part of your comment... –  Blake Jan 29 '13 at 4:35
    
fsutil behavior set SymlinkEvaluation L2L:1 R2R:1 L2R:1 R2L:1 –  STTR Jan 29 '13 at 4:36
    
Just tried it. After I ran that I ran the original command and it's still saying the syntax is invalid. I've checked and rechecked and it's the same as in the Microsoft help docs. –  Blake Jan 29 '13 at 4:38
    
technet.microsoft.com/en-us/sysinternals/bb842062.aspx Junction - Sysinternals Suite Utilities? eq mklink - work? FILESERVER\DATA\My Documents\Pictures - network resource? - mklink /d "c:\FILESERVER\Pictures" "\\FILESERVER\DATA\My Documents\Pictures" –  STTR Jan 29 '13 at 4:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.