Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Debian 6 and I have no network, I cannot connect to Internet or something, I am trying to figure out what could be possible wrong, but I don't know, I had to download a package when I was installing for the firmware of the network hardware, it says it "worked" but I don't know, because I still can not configure the network.

I tried doing /sbin/ifconfig and something like this is being shown

eth0     link encap Ethernet HWaddr 00:44:38:bd:eb:07 
         inet addr:192.168.1.24 Bcast:192.168.1.255 mask:255.255.255.0 
         UP BROADCAST MULTICAST MTO:500 metric:1 
         RX packets:0 errors:0 dropped:0 overruns:0 frames:0 
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 
         collision:0 txqueuelen:1000 RX bytes:0 (0.0B) TX bytes0 (0.0B) 
         Interrupt: 25

and at my /etc/network/interfaces I have something like this

auto lo 
I commented: 
    allow-hotplug eth0 
    auto eth0 
    iface eth0 inet static address 192.168.1.24 
    netmask 255.255.255.0 
    network 192.168.1.1 
    broadcast 192.168.1.255 
    gateway 192.168.1.1 
    dns-nameservers 192.168.1.1

I also did an eth0 up ... nothing seems to be working, any idea?? any help? I have 2 network boards... both have Internet connections.

Thanks in advance.

share|improve this question
1  
What do you mean that you have two internet boards, both with internet connections? –  Paul Jan 29 '13 at 5:44
    
Fixed your formatting since it was illegible before, please verify that everything is still correct. If you want DHCP on eth0, you'll need allow-hotblug eth0 <newline> iface eth0 inet dhcp in /etc/network/interfaces. I would then reboot and ping out to see. Your firmware is most likely loaded since you have the interface. –  nerdwaller Jan 29 '13 at 5:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.