Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Configuration file :/etc/samba/smb.conf as follows

[global]
        workgroup = workgroup
        server string = SambaServer
        security = user
        name resolve order = hosts lmhosts
;       encrypt passwords = yes
        guest ok = yes
        guest account = arun

[admin]
        path = /tmp/admin
        read only = no
;       browseable = yes
        guest ok = yes

I am able to ping the target Machine from Windows, but while trying

\\192.168.1.201\admin from windows PC, it shows Error: The Network path not found

One more thing I observer is while trying below command from another Linux Machine it shows below error,But while trying from the same Linux host(which the samba is configured) it working.

smbclient -U user1 -L \\192.168.1.201
connection to 192.168.1.201 failed (Error NT_STATUS_HOST_UNREACHABLE)
share|improve this question
    
Why are there two different IPs here? I see both 192.168.1.201 and 192.168.10.101. –  terdon Jan 29 '13 at 14:14
    
Did you create a samba password for user1 with smbpasswd -a user1? Samba can't use the system passwords because they're hashed and the only thing you can do with hashed passwords is verify them against the plaintext password. –  David Schwartz Jan 29 '13 at 23:22
    
Hi @terdon I thought to avoid actual IP address , but missed to modify in all lines. –  Arun Jan 31 '13 at 5:31
    
Hi @David Schwartz Yes I created a samba passwd that time , Actually it was problem with Firewall, Now I solved the issue .. Thanks for your interest guys.. –  Arun Jan 31 '13 at 5:33
add comment

3 Answers

the string format is wrong

smbclient -U user1 -L \192.168.1.201

change it to:

smbclient -U user1 -L 192.168.1.201 or smbclient -U user1 -L \YOURHOSTNAME

where hostname is the name you have given in your /etc/samba/smb.conf file

[global] *workgroup = YOURWORKGROUP*(change it to what ever is the name in your local net) netbios name = YOURHOSTNAME (must be different from workgoup name)

Also you have to set your desired host name using the command hostname YOURHOSTNAME

after that sudo systemctl restart smb.service *sudo systemctl restart nmb.service*

share|improve this answer
    
Hi @dbach , I both are working in my case smbclient -U user1 -L \\192.168.1.201 and smbclient -U user1 -L 192.168.1.201 –  Arun Jan 31 '13 at 5:35
add comment

Check samba is started:

"chkconfig --levels 235 smb on" "/etc/init.d/smb start"

This will auto start it at boot.

share|improve this answer
    
Sorry for poor formatting can't get back ticks on my phone! –  Shutupsquare Jan 29 '13 at 8:52
    
Hi @Shutupsquare, Yes samba is running , I just restarted once again using command "service smb restart" (Okay sure I will do that suggested modification to start it while booting) –  Arun Jan 29 '13 at 9:01
add comment
up vote 0 down vote accepted

Enabled Samba in Samba Server's Firewall solved the Issue [Menu: Sytem>Administration > Firewall]

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.