Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running a particular script and getting the following error :

  Error detected while processing /home/subhrcho/.vimrc:
  line   42:
   E538: No mouse support: mouse=a

This is the relevant portion of .vimrc file :

" In an xterm the mouse should work quite well, thus enable it.
 set mouse=a

Any idea as to what is wrong ?

P.S: I am using the following version of vim

VIM - Vi IMproved 7.0 (2006 May 7, compiled Nov 12 2010 05:24:19) Included patches: 1, 3-4, 7-9, 11, 13-17, 19-26, 29-31, 34-44, 47, 50-56, 58-64, 66-73, 75, 77-92, 94-107, 109, 202, 234-237

And my platform is :

Red Hat Enterprise Linux Server release 5.8 (Tikanga)

share|improve this question
    
Your Vim version is ancient (2006!!!). Go grab a recent package; you'll thank me later ;-) –  Ingo Karkat Jan 29 '13 at 10:22

2 Answers 2

Looking up the error (:help E538) brings you to the help for the 'mouse' setting:

Only works for certain terminals (xterm, MS-DOS, Win32, QNX pterm, BSD console with sysmouse and Linux console with gpm).

Also, check whether your Vim (you didn't state neither platform nor version) is compiled with mouse support:

:echo has('mouse')

If it is, it's due to the terminal; use another. If it isn't, you first need to find or compile a Vim binary that has mouse support.

share|improve this answer
    
Will I have to execute the :echo has('mouse') command from inside vim?When i executed this from vim , I got 1 . What does it mean ? –  Geek Jan 29 '13 at 9:34
    
Please see the question for version and platform –  Geek Jan 29 '13 at 9:51
    
Which terminal do you use? xterm? gnome-terminal? It should work in those. –  Ingo Karkat Jan 29 '13 at 10:20
    
has(mouse) doesn't mean that the mouse works in your environment, it means that the feature is compiled in. –  romainl Jan 29 '13 at 10:24
    
@IngoKarkat echo $TERM gives me xterm –  Geek Jan 29 '13 at 10:43

Alternatively, you could do this in your .vimrc:

if has('mouse')
  set mouse=a
endif

And the warning/error goes away...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.