Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run sudo on ArchLinux(on x86_64) and Fedora(on sh4 cpu). They behavior different.

sudo mkdir x
ls -l x
  • It shows drwxr-xr-x root root x on ArchLinux.
  • But shows drwxr-sr-x root mygroup x on Fedora sh4.

I'm wonder how to fixed this problem. I've tried put /etc/sudoers on Fedora, but it still create on wrong permission.

Defaults umask=0022
share|improve this question
1  
What does sudo umask return, and what are the permissions of the parent directory where you are creating the subdirectory? –  Paul Jan 29 '13 at 9:17
    
Thank you Paul. my root use 'busybox sh'. So, sudo umask will display unkown command. I guess you may found my problem, it is caused by the parent directory. –  Daniel YC Lin Jan 29 '13 at 12:24
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.