Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd like to have a file share on my Windows 8 computer so that I can connect to it as a guest from a Mac OS X 10.8. Authenticated file sharing works fine, but I'm trying to set up guest file sharing.

I've tried sharing a folder and giving "Everyone" and/or "Guest" read access, but the Mac only ever tells me the following when using "Connect to Server" and connecting to smb://myserver:

Access to your account on the server myserver has been denied

What magic must I do on the Windows 8 machine to get guest sharing to work?

share|improve this question

1 Answer 1

I would strongly suggest not activating "Guest" on your computer, it opens a whole can of worms. I would suggest creating a "Windows" user account in where it has a password so you can have someone you know log into the computer, and not have any Tom, Dick, and Harry from going in without you knowing about it.

To answer your question, go to your System Prefs --->Sharing

Make sure that your File Sharing is checked, once there there is a section for "Shared Folders" press the "+" button under it, and select the folder you wish to share. Once it's shared, it will show up on the list.

Once on that list, highlight it, from there you can select the option who has view only, or read and write access. If Windows user or "Guests" aren't on there, add them. I would strongly suggest not using guest as I have stated for a security reason alone.

Also on this window it will tell you the IP address, if you notice it will say afp://xxx.xxx.xxx.xxx that is the IP address you require to log into your computer from another on the same network.

Use that IP for the SMB:// address...it will/should work as well.

Also, if you are connected to the network, you should also see the computer in your network section... of windows 8, but I would suggest doing the SMB://xxx.xxx.xxx.xxx before attempting any other way.

If you need any more help beyond this, ask... but I think this should give you an idea of where to go from here.

IF this doesn't work, make sure your firewall on Windows 8 is not set up to block all incoming services, which Windows sometimes does without your notification when you have their firewall on.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.