Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Windows 7 machine that has a smart card reader. I have an application running on that machine that can successfully read the contents of the card.

I have another Windows 7 machine that I use to remote into the machine that has the smart card reader. When I am using the remote connection, the application can no longer access the smart card connected to the host machine. I understand that due to Remote Desktop redirection, I can only use smart card readers attached to the client machine.

Is it possible to turn off this redirection?

share|improve this question
    
Which remote desktop application are you using? – Ramhound Jan 29 '13 at 20:40
    
@Ramhound I am using mstsc. I have updated the title to specify "Remote Desktop Connection" for clarification. – markyd13 Jan 29 '13 at 21:18
    
Although I was unable to do this using RDP, I was able to use a different application as a workaround. Check out link. – markyd13 Jan 30 '13 at 17:59
up vote 4 down vote accepted

Unfortunately it is not possible.

I have a similar problem and was looking for a solution. What I found was a thread on social.technet.microsoft.com, where it says:

[...] It’s not possible. If you are connected through RDP, then your session is redirected to the client machine and will not see readers connected to the RDSH.

share|improve this answer
    
I found a technical explanation here: blogs.technet.com/b/instan/archive/2011/03/27/… – André Stannek Dec 10 '14 at 10:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .