Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a computer with Windows 7. Web pages open fine in Firefox, but in Internet Explorer, they open painfully slow... They'll load most of the page, but then hang up on something. I have no idea how long they take, because they take so long I've never waited to see. At least several minutes. The only page that opens up okay in Internet Explorer is www.google.com.

This does not happen under the Administrator account (everything works fine under that one), but it seems to happen under all other accounts.

I have tried

  • Resetting Internet Explorer to defaults
  • Making the other account an administrative account instead of standard
  • Upgrading to the Internet Explorer 10 customer preview (it was Internet Explorer 9)
  • Updating the graphics drivers
  • Switching network adapters
  • Manually disabling all addons through the Manage Addons menu

I even tried creating a completely brand new user account on the system, and the same thing happens under that one. The only account which has no problems is the Administrator account.

How can I fix this problem?

share|improve this question
    
Check your DNS settings. Use namebench tool from google to set the DNS servers. –  Alfabravo Jan 29 '13 at 17:21
    
Disable ALL add-ons and try it like that, let us know what happens. Click Start -> All Programs -> Accessories -> System Tools, and then click Internet Explorer (No Add-ons –  BroScience Jan 29 '13 at 17:37
    
Hmm, I did disable all the addons through "Manage Add-ons" within IE, did not try the separate shortcut though. Maybe it does something slightly different... I'll have to give that a try and report back. –  eidylon Jan 29 '13 at 17:43
    
@Alfabravo One question though, If it were a DNS issue, wouldn't that affect Firefox too, or not necessarily? –  eidylon Jan 29 '13 at 20:26
    
It would, indeed. I misread the initial statement. Could be some sort of issue with addons. Tried stopping antivirus and antistuff programs for a while? –  Alfabravo Jan 29 '13 at 21:05

2 Answers 2

up vote 1 down vote accepted

Disable ALL add-ons and try it like that, let us know what happens. Click Start -> All Programs -> Accessories -> System Tools, and then click Internet Explorer (No Add-ons)

share|improve this answer
    
Thanks for the answer. I had gone in through the Manage Addons menu and disabled all of them, but it didn't help. When I went through the no-addons Start Menu shortcut though, more showed up. Disabled them all and pinned it down to the Shockwave plugin. Thanks! –  eidylon Jan 30 '13 at 21:03

Anecdotally, I had a similar problem on one PC. I narrowed it down with pages that had Java objects on them (for example, this NPR page would hang in Internet Explorer as you describe, while most others worked) and once I uninstalled Java, it ran fine. Alternatively, I could have tracked down why Java was broken on that machine and tried disabling the Java plugin from Internet Explorer's setttings ("Manage Add-ons" from gear icon) or played with Java upgrades.

You might get a clue where the hang is happening on a page, by installing an HTTP monitor - like Fiddler - and see what is the last request the page makes before the hang.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.