Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The favorite links on the left side of all the folders have disappeared on my computer. Normally I had links to Downloads, Desktop and some more. But one day, they were all gone. And I can't find a way to get them back. Why doesn't it work by right click on it and press "Restore favorite links" (translated from swedish, don't know the uk/us name)

Image of how it looks like now

I think they may have disappeared becaused I removed a folder called "My links" in the "Alfred" folder. But it is weird because I haven't touched the "favorites" folder.

I have tried a lot to get it to work but with no luck.

share|improve this question
Can't you just replace them? What folder did you delete exactly? – Ramhound Jan 29 '13 at 21:10
Well. I haven't find a way to replace them. It's really weird. It was a folder called "My links" (directly translated from swedish, could be different on you computer) – Alfred Larsson Jan 29 '13 at 21:17
This will be a good experience for us, create another favorite, delete My Links and let us know if that deleted Favorites (I'd do it myself but I have no win8) – Kitet Jan 29 '13 at 21:37
"But it is weird because I haven't touched the "favorites" folder." - The Favorites folder contains your IE bookmarks, the Links folder contains the shortcuts you see under Favorites in Windows/File Explorer. – Karan Jan 29 '13 at 22:53
The folder is not My links but only Links. I deleted that myself and couldn't get a way to fix it. – Hunter Dec 31 '13 at 15:50
up vote 3 down vote accepted

Ordinarily, Restore favorite links should have worked; that's what it's there for. I just deleted the Links folder in Win7, then used that same option to regenerate them so Favorites was restored back to default.

At this point IMO you have two options:

  1. Create a new temporary user profile (or use an existing separate profile) and copy a working Links folder over to your profile. Naturally, custom items you previously added will not be restored.

  2. Since Links is just an ordinary folder with a hidden+system Dekstop.ini that's responsible for the magic, you could simply create a new folder by that name and copy over/recreate Dekstop.ini from a working instance of the folder (from a different profile on your or another PC). This is what it looks like on Win7, not sure if it's the same on WIn8 as I don't have access to it right now:


After doing either of these Restore favorite links should work (if not, reboot and try again).

share|improve this answer
Thanks. But how do I copy a folder from another account to my account? – Alfred Larsson Feb 2 '13 at 16:08
If C:\Users\UserName1 is not accessible from C:\Users\UserName2, simply copy the Links folder to a 3rd location temporarily, then log back in as the other user and complete the process. – Karan Feb 2 '13 at 16:36
This new user, Can I copy the folder from Virtualbox windows 8 installation? – Hunter Dec 31 '13 at 16:01
Late answer. They came back when I upgraded to Windows 8.1 – Alfred Larsson Oct 2 '14 at 13:55

This worked for me:

  1. Open file explorer and click on This PC.
  2. Go to the View tab and select the Options dropdown.
  3. Select Change folder and search options from the dropdown.
  4. Click on the check box for Show Favorites in the Navigation pane.
share|improve this answer

I had just the same problem, so I just follow these steps to get back my favorite links:

  1. First, you open the file explorer

  2. Then you select any folder (as music, documents, etc.)

  3. After that, you drag the folder to favorites until it appears a message asking you if you want to create a link to favorites

  4. later on search in the folder you just dragged, and there should be a folder called "links"

  5. Following this, you can go over favorites in the left side of the window and use the right click and select restore favorites

  6. Finally close the window and open file explorer again.

This ought to do the trick, hope it functions to you

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .