Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have windows 7 on one partition and was installing LinuxMint on another partition (I also have a 3rd data partition) and towards the end of the installation it said this message: executing grub-install failed.

Now I chose to just continue and restarted. Right now it boots into windows directly.

I would like to know how to proceed i.e. enable the dual booting. I am also assuming that Linux mint installed fine, which might not be the case, and that I just need a boot loader to manage the loading of the 2 OSs.

NOTE: when I had the installation cd there was about 15 volumes or partitions that it recognized. It was basically those 3 partitions I mentioned above just repeated. Not sure if this is an issue or not.

EDIT: I have two disks in raid0

share|improve this question

migrated from stackoverflow.com Jan 30 '13 at 2:13

This question came from our site for professional and enthusiast programmers.

    
Is this a hardware raid or a (so called) fake raid? Are you sure you configured that raid properly? –  hek2mgl Jan 29 '13 at 23:27

3 Answers 3

You'll have to

  • boot a (live) linux from usb stick or live cd
  • Mount your Mint partition
  • Open a terminal and start manual configuration of grub2

I've done that really frequently. Don't worry it doesn't hurt! Its just the bootloader ;)

This tutorial from Linux Mint might be exactly what you are searching for.

share|improve this answer
    
Question for number 2, first gparted does not have a column with mount point, but i see under file system the one for mint which is of type ext4, now I want to point out 2 things. 1) the path is /dev/mapper/isw_fjadfjejh_volume0p5 , is that normal? –  user1253073 Jan 29 '13 at 22:34
    
2) the entry for this in gparted is actually a subentry where the parent entry is /dev/mapper/isw_fjadfjejh_volume0p4. Do I mount the parent or the sub-entry? –  user1253073 Jan 29 '13 at 22:35
    
OK I did it for both, its saying this error: mount: can't find /dev/mapper/isw_fjadfjejh_volume0p5 in /etc/fstab or /etc/mtab –  user1253073 Jan 29 '13 at 22:41
    
wait a sec... will have to read point 2. of that tutorial –  hek2mgl Jan 29 '13 at 22:41
    
do you know now which /dev/sd? belongs to your mint partition? –  hek2mgl Jan 29 '13 at 22:48
up vote 1 down vote accepted

The problem I had was that I had two drives in raid 0. The ubuntu installer does not detect the drives are in raid and will install anyways. The boot loader however fails to install because of the raid setup.

What is needed is to get the alternate OS installation image and a few additional partition setup steps before it is possible to install ubuntu in raid. So the standard ubuntu installation image will not work in this case.

share|improve this answer

You can boot the live cd, and run this command:

sudo grub-install --root-directory=/mnt/ /dev/sdX

Where /dev/sdX is your hardrive.

share|improve this answer
    
I typed the command below, and got failed to get canonical path of cow. The path is what I think is the path for the partition, but it does not start with sd... sudo grub-install --root-directory=/mnt/ /dev/mapper/isw_fjadfjejh_volume0p5, any help is appreciated. THanks –  user1253073 Jan 29 '13 at 22:45
    
its also saying unrecognized option --root. thanks. –  user1253073 Jan 29 '13 at 22:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.