Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My windows are suddenly jumping to different monitors when I type numbers. I'm not exactly sure what I did to cause this problem.

I have a 6 monitor configuration, and when I went into the Screen Resolution menu, I noticed that the particular number I press matches the number that is displayed when I click "Identify". This happened with a window in two completely unrelated programs, so it's almost certainly an OS thing, not internal to that software.

I do not have AutoHotKey, UltraMon, or any other similar thing installed. Anyone know what's wrong? Is it possible I have a key stuck somewhere?

Some other facts:

  • The number DOES type in the window, it's not being wholly consumed by some other program.
  • Using the number pad doesn't do this, only the numbers in the top row of the keyboard
  • To get up to 6 monitors, I have 2 USB-to-VGA adapters. I wonder if something is wrong with the driver? I have two of these. Manual
share|improve this question
1  
Check to see if StickyKeys is on. it may have locked a key like Shift, Alt, Ctrl, etc. –  Frank Thomas Jan 30 '13 at 14:43
    
I don't think it's a StickyKeys issue, since pressing Shift+1 (!), Ctrl+1 (usually bound to something in the application), Alt+1 and Windows+1 don't do this functionality. –  durron597 Jan 30 '13 at 14:58
    
have you checked your video card driver configuration? usually if there are screen switching hotkeys available, they are created there. its worth a look. what kinda video card do you have? –  Frank Thomas Jan 30 '13 at 17:10
    
@FrankThomas I have two AMD Radeon HD 7000 series... but we bought three of these computers, and it only happens on the one with the USB to VGA drivers (the other two don't have 6 monitors, only 4) –  durron597 Jan 30 '13 at 17:12
    
look in the Catalyst Control Center and see if you have any window switcher hotkeys defined. support.amd.com/us/GPU_TechDocs/ccc_user_guide.pdf –  Frank Thomas Jan 30 '13 at 17:16

2 Answers 2

up vote 4 down vote accepted

I use a USB to VGA adapter and my adapter came with a program called "super utility" and aside from providing shortcuts to monitor settings, it provides the functionality of assigning hotkeys to move windows between monitors. Mine acted exactly as you describe, acting almost as if sticky keys were enabled (which mine are not) I was not pressing the combo for doing such a function, however, when I disabled the the the utility, it fixed the issue.

I hope this gives you something else to look into.

share|improve this answer
    
Actually, I realized something to this effect some time ago, but I forgot to update this thread. Have some reputation on me, as this is the right answer. –  durron597 Aug 27 '13 at 16:55

I had the same problem and also have a usb vga adapter that came with the Super Utility. I've had this utility installed and running for nearly a year before it started acting like this after I rebooted today. Right clicked the system tray icon for Super Utility, chose Multi-Display Control Panel and then clicked the Disable button. After that my windows stay put when I press the 1 or 2 keys. According to the Hotkey list it was supposed to only do this for CTRL-1 or CTRL-2 but mine did it when I pressed the keys alone, with shift, etc.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.