Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install cpanminus through the terminal using the command given on the website:

sudo cpan App::cpanminus

However I receive the following error:

N01-0545---MB:CPAN-1.9800 sucadmin$ sudo cpan App::cpanminus
Going to read '/Users/sucadmin/.cpan/Metadata'
  Database was generated on Tue, 29 Jan 2013 00:29:02 GMT
Running install for module 'App::cpanminus'
Running make for M/MI/MIYAGAWA/App-cpanminus-1.5019.tar.gz
Checksum for /Users/sucadmin/.cpan/sources/authors/id/M/MI/MIYAGAWA/App-cpanminus-    1.5019.tar.gz ok Going to build M/MI/MIYAGAWA/App-cpanminus-1.5019.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for App::cpanminus
make: *** No rule to make target `/System/Library/Perl/5.12/darwin-thread-multi-    2level/CORE/config.h', needed by `Makefile'.  Stop.
  /usr/bin/make -- NOT OK
'YAML' not installed, will not store persistent state
Running make test
  Can't test without successful make
Running make install
  Make had returned bad status, install seems impossible

Based on this post I tried what they suggested, and got the following:

cpanm (App::cpanminus) 1.5020 on perl 5.012003 built for darwin-thread-multi-2level
Work directory is /Users/sucadmin/.cpanm/work/1359493476.3491
You have make /usr/bin/make
You have LWP 5.837
You have /usr/bin/tar: bsdtar 2.8.3 - libarchive 2.8.3
You have /usr/bin/unzip
Searching App::cpanminus on cpanmetadb ...
--> Working on App::cpanminus
-> OK
Unpacking App-cpanminus-1.5020.tar.gz
Entering App-cpanminus-1.5020
Checking configure dependencies from META.yml
Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.56)
Configuring App-cpanminus-1.5020
Running Makefile.PL
Checking if your kit is complete...
Looks good
Writing Makefile for App::cpanminus
-> OK
Finding PREREQ from Makefile ...
Checking if you have ExtUtils::MakeMaker 6.31 ... Yes (6.56)
Checking if you have Module::Build 0.36 ... Yes (0.3603)
Checking if you have ExtUtils::Install 1.46 ... Yes (1.55)
Building and testing App-cpanminus-1.5020
make: *** No rule to make target `/System/Library/Perl/5.12/darwin-thread-multi-        2level/CORE/config.h', needed by `Makefile'.  Stop.
-> FAIL Installing App::cpanminus failed. See /Users/sucadmin/.cpanm/build.log for     details.

I'm using OS X Version 10.7.5 and gcc version 4.2.1.

Any help as to what is going wrong?

share|improve this question

migrated from Jan 30 '13 at 17:47

This question came from our site for professional and enthusiast programmers.

Have you tried bootstrapping via 'curl -L | perl - --sudo App::cpanminus' – ugexe Jan 29 '13 at 22:36
If the spaces or tabs in /System/Library/Perl/5.12/darwin-thread-multi- 2level/CORE/config.h are not an artefact of the way you're copy'n'pasting, then you need to find out why you have the spaces or tabs in the name. If they are an artefact, then you need to investigate why you don't have /System/Library/Perl/5.12/darwin-thread-multi-2level/CORE/config.h present. It's there OK on my Mac OS X 10.7.5 machine — though I'm using my own Perl 5.16.2 rather than the system Perl 5.12.3. I can trade perl -V output with you if you think that will help. – Jonathan Leffler Jan 30 '13 at 1:18
Personally, I never modify the system's installation of Perl; I never use it, either. I always build my own so that I can be as up-to-date as I choose. But that's just me. – Jonathan Leffler Jan 30 '13 at 1:19
Could you please post the content of /Users/sucadmin/.cpanm/build.log relative to cpanm installation failure? – smonff Aug 22 '13 at 4:44

The recommanded process for Cpanminus installation is the following :

curl -L | perl - --sudo App::cpanminus

Try this, it never failed me yet.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.