Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I thought I'd make my first SuperUser question relatively simple, though it's the kind of question that may not get many responses as I'm not directly involved with the issue.

A colleague does his development in Windows XP running in Parallels on his Mac. We've just migrated our VSS repository to SVN, and we've gone with TortoiseSVN as our client of choice with the Ankhsvn plugin for Visual Studio.

On his XP instance, after installing TortoiseSVN, browsing through folders using Explorer is extremely slow; about 15 - 30 seconds before the contents of the next folder displays. It's the slowest when opening My Computer. Once he reaches a folder that contains the working content of an SVN project, Explorer behaves quickly again as expected. It seems that TortoiseSVN may be spending a bunch of time searching subfolders for stuff so it can do its icon-overlay thing, but that's just a guess.

I've used TortoiseSVN for years on both XP and Vista on far less powerful machines without any issues with Explorer, so I'm attributing the slowness to it being run in a VM, though that may not be the actual issue.

So has anyone encountered similar performance issues, and/or know of a fix? Keep in mind that any requests to make changes to his configuration will need to be communicated and thus my response time might be slow.

Thanks everyone!

share|improve this question

4 Answers 4

Settings dialog->Icon Overlays->Exclude paths: Set this to e.g.,

C:\*

Then set the include paths to the path where the working copy is, e.g.

c:\users\mydocuments\myworkingcopy*
share|improve this answer
1  
Here's a link with a little more detail: paraesthesia.com/archive/2007/09/26/… –  John Allers Nov 13 '09 at 12:13

I ran into very similar issue several times, and the "cache" tweak did notwork, and I was inspired by this post: https://groups.google.com/d/msg/tortoisesvn/IehAouUWrnA/srbHrGlCVR4J and tried using Wireshark myself to monitor what had happened during context menu launch.

As expected, several netbios name queries were found searching for a machine name but timed out. Then I remembered I had changed my computer name without restarting, so the tortoise svn is looking for that new name! So I did a reboot and things all went back to normal.

Hope this experience helps.

ADD: You can also try using Process Monitor (http://technet.microsoft.com/en-us/sysinternals/bb896645) to trace whatever happens when the lagging occurs. It always helps to identify abnormal registry/file/network access.

share|improve this answer

I've seen similar symptoms (slow responses in Explorer) from tortoise, but in a different context (working copy was on a network share). In my situation, the solution was to go into Tortoise' settings and turn off Icon Overlay caching.

share|improve this answer
    
Tried it; no change. Does Explorer need to get restarted or anything? –  Cory Larson Oct 12 '09 at 18:41
    
It's worth a shot. Since it's a shell extension you would need to restart explorer at least, probably windows, to be sure everything is cleared out. –  Joel Coehoorn Oct 12 '09 at 19:55

You can set the "Include paths"-setting in TortoiseSVN to let it know that it should only display overlay icons on the directories where you have your SVN project. The setting is found in Settings->Icon Overlays->Include paths.

share|improve this answer
1  
Tried it; no change. Does Explorer need to get restarted? –  Cory Larson Oct 12 '09 at 18:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.