Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Snow Leopard on a MacBook Pro. My Finder has decided to be very busy, and neither restarting Finder nor a reboot cools it down. Spotlight doesn't report activity, Time Machine isn't busy, yet top -ocpu reports Finder is running between 30% and 100%.

Update: none of the suggestions have worked. At this point (three months after first asking the question), I'm resigned to wait until the new MacBook Pro comes out and start with a clean install. Very frustrating that there's no way to investigate what the Finder gets stuck on.

share|improve this question
    
I'd be happy to look at your spindump or lsof output, @Peter. –  Spiff Apr 5 '10 at 4:36

4 Answers 4

up vote 8 down vote accepted
+50

The shell command...

sample Finder

...will monitor all the function calls being made by the Finder and create a text file showing the call stacks of each of the Finder's threads. Even knowledgeable non-programmers (super users, if you will) can often glean valuable insights from this. It's also a great thing to attach to a bug report to Apple via http://bugreport.apple.com/ .

This is basically the same as the "Sample process" button in Activity Monitor.


Update: Ooh, even better than sample(1) is spindump(8), which is like sample but adds visibility into what the kernel is doing when the app's threads are blocked waiting for the kernel.

sudo spindump Finder

The text file it creates in /tmp will require root privs to read, since it might contain privileged information.


More clues could be gleaned from...

lsof -p $PIDOfFinder

(where $PIDOfFinder is the process ID of the Finder, which you can find via ps.)

Looks like you can get that same information in Activity Monitor. Select Finder, hit the "Inspect" button, and select the "Open Files and Ports" tab.

Another interesting data point would be whether or not the problem happens for a new, clean user account on the same system. Just create a new user account, log out of your normal account (don't use Fast User Switching -- we don't want your "bad" instance of the Finder staying running in the background and confusing things), and log into the new clean account and see if the problem happens there too.

Are you running any InputManager hacks, including SIMBL-based stuff, or Unsanity Application Enhancer (APE) "haxies"?

Does the problem happen when booted into "Safe Mode" (that is, booted with the <shift> key held down)?

share|improve this answer
    
@Peter, it's either all that or the clean install! :P –  Cawas Mar 30 '10 at 18:57
    
gave up. figured in the end it was easier to by a new macbook pro with a clean install then to sort this out. there was something damaged in the installation. but i appreciate the learning experience. :-) –  Peter S Magnusson Jun 7 '10 at 1:18

Sadly, Apple doesn't provide any activity monitoring functionality for the Finder. So I would think that the best solution, if the Finder continues to misbehave, is to move its preference file: ~/Library/preferences/com.apple.finder.plist out of the preferences folder and restart it.

share|improve this answer
    
Certainly a good answer, but I would suggest testing a little before nuking the finder preferences... –  Benjamin Schollnick Oct 12 '09 at 19:55
    
as suggested by Benjamin i tried other things first, to no avail (the problem came back). nuking the prefs seems to have done the trick. –  Peter S Magnusson Oct 23 '09 at 22:45
    
nope it didn't. problem has continued to be persistent. –  Peter S Magnusson Mar 28 '10 at 23:58
2  
@Peter If i did for a little bit, something must be messing with the finder preferences. Have you tried checking the Console log in that meanwhile? –  Cawas Mar 30 '10 at 18:55

If Activity Monitor just shows "Finder" at a high percentage, you don't necessarily have a easy way to find out what is causing it.

1) Check to see if you have any file servers mounted. If so, eject them, this includes MobileMe. 2) Hit Command-J. Turn off "Use Relative Dates", and "Calculate All Sizes". Do you see a difference?

I have seen where Calculate all sizes will peg the CPU for a bit until it finishes calculating the entire tree.... And it has to periodically review to ensure that new files haven't been added, or modified... But once it is done scanning, it calms down quite a bit....

share|improve this answer
    
thanks, tried that, no change. –  Peter S Magnusson Oct 23 '09 at 22:42

Nothing is going to magically tell you what is wrong, but this script will tell you what kind of aftermarket garbage you've installed on your machine so that you can begin the removal process on your own:

http://khiltd.com/software/consultants_canary

I'd pay particular attention to QuickLook and Spotlight plugins, but there's really no telling what people put on their machines.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.