Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to have a play with ptunnel, I have it running (listening) on my raspberry pi in my DMZ and I can connect to it from my LAN and tunnel ssh over it, but I can't get it to work over my LAN.

I have tried connecting from work and also from my laptop using using my phone as a 3G modem, but am having no luck. I'm running both server and client with verbosity level 4.

I know that my machine in the DMZ is able to receive and respond to ICMP echo because when it is running I can ping it from work and when using my phone as a 3G modem and I know ptunnel is receiving the ping request because it outputs the following line to stdout:

[vbs]: Ignored incoming packet.

When I try to connect over the WAN, I get the following messages from ptunnel:

Client:
[inf]: Incoming connection.
[evt]: No running proxy thread - starting it.
[dbg]: Adding proxy desc to run loop. Type is user. Will create socket: No
[dbg]: Starting ping proxy..
[dbg]: Attempting to create privileged ICMP raw socket..
[inf]: Ping proxy is listening in privileged mode.
[vbs]: Sending proxy request.
[dbg]: Resending packet with seq-no 0.
(last message repeats over and over...)

Server:
[inf]: Incoming tunnel request from PUBLIC_IP_REMOVED.
[inf]: Starting new session to 127.0.0.1:22 with ID 49653
[dbg]: Adding proxy desc to run loop. Type is proxy. Will create socket: Yes
[dbg]: Received ack-series starting at seq 65535
[err]: Dropping duplicate proxy session request.
[dbg]: Received ack-series starting at seq 65535
[dbg]: Resending packet with seq-no 0.
(last 3 messages repeated over and over...)

Any ideas why? Is my router not putting my machine properly in the DMZ?

share|improve this question
add comment

migrated from security.stackexchange.com Jan 31 '13 at 0:10

This question came from our site for Information security professionals.

1 Answer

I'm fairly sure it's my crappy router because even though the router is turned off, there is something in the router logs about the firewall detecting an ICMP attack. Stupid thing. Time to upgrade to something better than what the ISP gives out for free.

share|improve this answer
    
Actually this is not to do with my router. It also happens when using ubuntu on Amazon EC2 as my ptunnel server –  Grezzo Mar 6 '13 at 11:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.