Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

putting my new laptop to sleep, and it takes about 30 seconds before the power-button starts doing the "blinking" that lets me know it's sleeping. during this time (between me pushing the sleep button and the blinking) my computer's screen is off and it's completely unusable.

resuming from sleep is snappy enough, but start-sleep to sleeping is frustrating slow. any suggestions on how to speed it up?


some things i tried.....
I have tried disabing hibernate (just in case) but that has no effect. also i tried the hybrid sleep but that also seems to have no effect.

i'm using a lenovo yoga 13, and so also tried the oem's specific power configuration tool, but that also has no effect on my problem.

share|improve this question
    
do you have a lot of disk activities during that 30 seconds period? also, have you tried to go into sleep mode right after a fresh boot up? –  Ray Cheng Jan 31 '13 at 7:19
    
i didn't look, but i think no. i wasn't running any apps (i didn't install any) however i can't say that windows wasn't doing something on it's own. –  JasonS Feb 1 '13 at 3:15
    
fyi my mitigation is to only have it fall asleep after 5 min inactivity, instead of the normal "close lid" –  JasonS Feb 1 '13 at 3:17
    
Are you sure hybrid sleep is completely disabled (it is enabled for desktop PCs by default)? This sounds awfully like it saves RAM to HDD, then sleeping. It can also be pre-standby cleanup, but that shouldn't take 30 seconds unless the system has been up for a long time with a lot of activity. –  Jan Schejbal Feb 5 '13 at 14:52

2 Answers 2

This is a either a compatibility issue with your chipset or something as simple as changing the BIOS "suspend" setting. If it's a chipset issue, consider making sure you have all the latest driver updates from Windows and your manufacturer.

To check your BIOS settings, see this article.

I had this same issue and found a it was two things; BIOS setting and too many processes to suspend.

share|improve this answer
    
thanks for the help, my machine (lenovo yoga 13) unfortunatly doesn't have power options in bios, and i was having this issue with a default install of win8. so maybe a chipset issue (i installed all the latest drivers) –  JasonS Feb 7 '13 at 9:10

It could have been some devices/drivers requesting that the computer didn't enter into sleep mode.

Referring to http://www.eightforums.com/general-support/36103-windows-8-1-shut-down-sleep-issues.html#post329714 as it might help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.