Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used Torsock and usewithtor fine when I had MAC OS X 10.6, and didn't use it for a while. I upgraded to Mountain Lion a few months ago, and I tried to use it but no luck on it. Output is following:

dyld: could not load inserted library: /opt/local/lib/torsocks/libtorsocks.dylib

Trace/BPT trap: 5

I'm not sure why it complained about dyld which locates at right location. It also produced perl-dynamic error log:

Process:         perl-dynamic [13084]
Path:            /usr/local/ActivePerl-5.10/bin/perl-dynamic
Identifier:      perl-dynamic

Version:         ???
Code Type:       X86 (Native)
Parent Process:  bash [13531]
User ID:         501

Date/Time:       2013-01-31 03:14:15.638 -0500
OS Version:      Mac OS X 10.8.2 (12C60)
Report Version:  10

Interval Since Last Report:          429027 sec
Crashes Since Last Report:           38
Per-App Crashes Since Last Report:   4

Anonymous UUID:                      1EF6A147-F21F-6CA7-6BA2-E9A910B314C1

Crashed Thread:  0

Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  could not load inserted library: /opt/local/lib/torsocks/libtorsocks.dylib

Binary Images:
    0x1000 -     0x1ffc +perl (???) /usr/local/ActivePerl-5.10/bin/perl
0x8fe66000 - 0x8fe98e57  dyld (210.2.3) <23DBDBB1-1D21-342C-AC2A-0E55F27E6A1F> /usr/lib/dyld

Model: MacBookPro5,5, BootROM MBP55.00AC.B03, 2 processors, Intel Core 2 Duo, 2.26 GHz, 8 GB, SMC 1.47f2
Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x0198, 0x393930353432382D3030352E4130324C4620
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x0198, 0x393930353432382D3030352E4130324C4620
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.0.9f33 10885, 2 service, 18 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: FUJITSU MJA2160BH FFS G1, 160.04 GB
Serial ATA Device: HL-DT-ST DVDRW  GS23N
USB Device: iPhone, apple_vendor_id, 0x12a0, 0x24100000 / 3
USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0x24400000 / 2
USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0x26500000 / 2
USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06100000 / 2
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8213, 0x06110000 / 4
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0236, 0x04600000 / 3
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x04500000 / 2

I tried to find similar case on google, but also no luck. Any idea how to fix this problem?

share|improve this question

I just installed "torsocks" on my Macbook Pro running 10.8.4 using MacPorts.

Possibly, try removing the version you have and reinstall.

  1. Download MacPorts here

  2. Open your Terminal: sudo port install torsocks

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.