Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Thunderbird's message filters (ToolsMessage Filters…) seem to only fire on Inbox automatically. If you want to filter on subfolders, you'd have to start this filter manually (ToolsRun Filters on Folder).

How can I filter mails in subfolders automatically, too?

I found the (now EOL'ed) extension Filter Sub Folders. There it says:

It turns out that there's already functionality to do filtering on sub folders in Thunderbird, it's just not well documented (indeed, it's barely documented at all). It can be enabled by setting the preference "mail.server.default.applyIncomingFilters" to true, or can be applied per folder by setting the "applyIncomingFilters" property to a folder.

I searched for the property mail.server.default.applyIncomingFilters, but didn't find it. So I added it (as string, according to this issue) and set its value to true. But this didn't work. After restarting TB the mails in subfolders didn't get filtered.

FilterQuilla (https://addons.mozilla.org/en-us/thunderbird/addon/filtaquilla/) is reported to be able to set that property, although I haven't tested it.

It doesn't say anything about that in the description.


Similar (but not same) question: How can I get Thunderbird to automatically move messages?

See also (useful to have it combination): How can I get Thunderbird to check subfolders on IMAP?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

To make filtering works for subfolders: create a new string preference "mail.server.default.applyIncomingFilters" to "true". Even if it seems odd, do NOT create a boolean setting, it has to be a STRING setting with the value "true".

Source: http://forums.mozillazine.org/viewtopic.php?f=39&t=1444045&p=12768821#p12768821 see reply of "geoyo1"

share|improve this answer
    
Thanks for your answer. Unfortunately, this doesn't work for me. As I documented in my question, I already tried this. I tried it again now, but it still doesn't work. I added the string preference, but after restarting TB nothing changed. The filter still doesn't apply to the subfolder automatically. –  unor Apr 3 '13 at 15:07
    
Oh, it worked for a mail now. Seems to work only when visiting the folder manually. I'll test some more. –  unor Apr 4 '13 at 11:26
    
I don't understand why, but sometimes it takes a long time until the messages are moved. However, as soon as I visit the folder, the filter apply immediately. It's a solution, so I accept your answer. Thanks for pointing me again to this string preference :) –  unor Apr 8 '13 at 14:14
    
Can confirm this works on Thunderbird 31 (Ubuntu) –  paul.ago Aug 26 at 14:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.