Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a ReadyNas Duo that I recently purchased and configured on my local home network. I'm an AT&T DSL subscriber using their default 2701HG-B Gateway (2Wire) wireless router.

Basically, I have managed to configure my ReadyNAS, and can access HTTP shares and WINS shares just fine, but cannot get access to it via FTP. I've enabled it in the 'Standard File Protocols' section in the UI, and made a share have read/write default access via FTP.

My settings:

Port: 21
Authentication mode: User Allow upload resumes: Yes
Passive ports: 1024-65535
Masquerade as: (empty, but I've tried the internal IP address).

I've even poked around at my router, which has a firewall, and even tried to poke a hole for the 'FTP Server'app for the ReadyNAS. Doesn't seem like I should need to do this, or should.

Any ideas what else to check?

share|improve this question

migrated from serverfault.com Oct 12 '09 at 19:19

This question came from our site for system and network administrators.

2 Answers 2

Solved my problem in a convoluted way. I unselected FTP to stop the service, which gave me an 'Error Stopping Service' issue. However, the service did stop, and when I restarted the service, things were working properly. So basically, the service was wedged, and a refresh fixed the issue.

share|improve this answer

I had this issue too and even though I had multiple shares with FTP enabled and had stopped the server (receiving the error) and restarting, still no luck. Not even a reboot. Unfortunately for me, I had to get rid of all the shares, stop/restart service THEN it worked. Good thing I was still just setting it up and there wasn't data there.

share|improve this answer

protected by studiohack Apr 27 '11 at 0:44

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?