Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have decided to take the next step in learning linux and have taken on GENTOO. I am following the tutorial on this site

I am currently at 11 "Get the stage 3 tarball (assuming you're doing a stage 3 install, which we are)" and I am trying to connect to links2.

but I am totally new to trying to connect to a wifi on gentoo.

I have looked at many forums and blogs and have come across WPA_SUPPLICANT. my wireless provider is UPC (located in Ireland) so it is WPA/WPA2.

I have tried to follow many tutorials for example

but when I try to follow them (one tutorial said to use the command )

$ emerge wpa_supplicant

in order to install it, it was not recognised as a command. (one example of many issues)

I have also tried to find the driver but cannot find out which one it is, I'm installing it on a Sony Vaio W12s1e netbook with an intel atom processor and 1gb RAM

I have been at this for awhile and just need to set up my wifi in Gentoo

If you can tell me how it would really help me

share|improve this question

migrated from Jan 31 '13 at 17:10

This question came from our site for professional and enthusiast programmers.

Shell commands are case-sensitive and it should be emerge wpa_supplicant. Also, don't follow some random website, but the official Gentoo installation guides from – Benjamin Bannier Jan 31 '13 at 16:42
Hey thanks for the reply, yes I put them in the way they were suppose to put them in. I was just emphasising the code part. I was looking at that site too, I am just really really confused on how to set up my wireless, WPA and wpa_supplicant – user1334371 Jan 31 '13 at 16:46
The gentoo link you posted states that you should run emerge net-wireless/wpa_supplicant. Have you tried his? Also, please include the error messages you are getting. – terdon Jan 31 '13 at 17:16
Hi yes I did and it stated that "emerge: command not found" – user1334371 Jan 31 '13 at 17:27
I would use a different Linux distro other than Gentoo. Gentoo is overly complicated... and overly complicated does not equate to a better understanding of Linux. – Keltari Jan 31 '13 at 17:32

You haven't got far enough through the installation to use emerge yet. The "chroot" step enters you into your new installation where you can install additional packages. The point of getting net access in the beginning is so that you can download a Portage tree snapshot but you could get hold of this some other way like downloading it onto a USB stick on another system. Generally speaking, I would steer clear of wireless until you're up and running because configuring it from the command line isn't much fun. Once you have a desktop, you can use graphical tools like wpa_gui.

And do please ignore the guy above. Gentoo was my second distro back in 2002 and I probably knew about as much as you did. I'm still using it to this day and my Linux knowledge is now a very big part of my day job. I have Gentoo to thank for that.

share|improve this answer
thank you very much for your advice. I will start again from beginning and use a wired connection. I understand it is very hard but I feel if you never quit you will accomplish anything eventually :) Thank you – user1334371 Jan 31 '13 at 22:38
Alternatively, use one of the LiveDVDs, to have working wifi while installing. – robbat2 Dec 4 '13 at 1:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .