Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My computer runs LXDE over Ubuntu (they call it Lubuntu) and I experience an interesting problem. I connect 2 screens to my computer so I expect that if I have 2 virtual desktops then one of them will show up at first screen, and second at another screen. But instead, I see the same picture including simultaneously moving mouse cursor, at both screens.

So I tried to configure viewports using xrandr. It worked well and now my desktop expands to both two screens so when I move the cursor to the right edge of the first, it shows at the left side of the second.

But! Switching between virtual desktops leads to seeing both screens for one of them or both screens for another. I can't set up screens to show desktop 1 at the left one, and desktop 2 at the right one.

Has anybody came across same problem? How did you solve it?

share|improve this question

1 Answer 1

Add or modify file ~/.config/autostart/lxrandr-autostart.desktop

In the example below:

  • left monitor is DVI-I-1 1920*1200
  • right monitor is VGA-1 1280*1024

Try xrandr to see name and possibily of your monitor.

lxrandr-autostart.desktop file consists of:

[Desktop Entry]
Type=Application
Name=LXRandR autostart
Comment=Start xrandr with settings done in LXRandR
Exec=xrandr --output DVI-I-1 --mode 1920x1200 --pos 0x0 --output VGA-1 --mode 1280x1024 --pos 1920x0
OnlyShowIn=LXDE
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.