Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows Vista (32 bit Home Premium SP2) and despite having Kaspersky Internet Security on, fully up to date and activated, cannot stop the security warning icon from showing.

I click on that icon and select Open Now and yet it still shows the warning.

windows security dialog

(The above screenshot includes translated portions.)

share|improve this question
    
Can you please translate the security center comments in English. –  Ganesh R. Oct 12 '09 at 19:59
    
Simdi Ac : Activate Now –  NT. Oct 12 '09 at 20:22
    
Virusten Koruma : Virus protection –  NT. Oct 12 '09 at 20:23
    
Here is translated picture : img240.imageshack.us/img240/3466/vistaerror.jpg –  NT. Oct 12 '09 at 20:32
    
What is the exact (english) name and version of your Kaspersky product? –  harrymc Oct 29 '09 at 14:45

4 Answers 4

Usually this problem with Windows Security Center works itself out after several restarts and the system gets to recognize Kaspersky. The problem is even though there are false warnings, especially soon after installing KIS, sometimes the WSC warnings are accurate.

Whatever the case it's a good idea to get in the habit of being sure to notice that the "K" icon in the taskbar is red. It is also a good idea to open KIS and make sure the bar on top is GREEN and says "Your Computer Is Protected".

If you wish to force the issue :

  1. In: Start >Run > type: services.msc to display all services
  2. Click on on Windows Management Instrumentation
  3. Click on the Stop icon (black rectangle) to stop the Windows Management Instrumentation service.
  4. Rename the C:\windows\system32\wbem\repository folder, wait for it to be recreated (can take a bit of time).
  5. Restart the WMI service & restart the computer.

If something goes wrong, you can always rename back the folder.

Explanation:

The wbem folder is where Windows stores the information it sends to the Security Center about the antivirus and firewall installed. Sometimes, the information there gets corrupted, which results in erroneous information being sent, which is when you are told you don't have an antivirus or a firewall.

If you know you do, it's the communication that is at fault, not the applications per se. By following the instructions above, and removing that folder, you force Windows to check the security applications installed all over again and reset itself. When folder is recreated, the correct information should be displayed after a reboot.

This should solve the problem, and in most cases it does, but sometimes the error is something else. You don't harm anything by giving it a go.

This happens with all anitiviruses and firewalls now and then, under certain conditions - it's not specific to Kaspersky.

share|improve this answer
    
I applied what u said.New repository folder was created but it still gives error about my security software. –  NT. Oct 13 '09 at 17:33
    
Some people on the web said that the problem gets fixed by itself after a few reboots. –  harrymc Oct 13 '09 at 19:21

Is the anti-virus up to date & have you enable ALL the features of Kaspersky or have you disabled anything?

share|improve this answer
    
It's up to date,fully activated and nothing was disabled. –  NT. Oct 12 '09 at 20:33

In Vista SP2 and Windows 7 Microsoft changed API for reporting anti-virus status.

Downloading newest version of Kaspersky or downloading one intended for Windows 7 should sort out this problem.

share|improve this answer
    
my KIS is the last version and fully activated. –  NT. Oct 12 '09 at 20:24

Or a solution that has not been suggested yet. Turn off the Security Center notification about Anti Virus. Click on 'Change the way Security Center Alerts me'

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.