Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've started up multiple computers and run servers trough IIS multiple times. I had no problem setting up servers on Windows 7, 8 Developer, 8 Consumer, but now that I have Windows 8 Pro, I can't seem to get it to work.

My website/server is reachable on the local computer trough my domain name. It's also reachable on my phone on the same network. But when I put my phone on 3G, or if a friend (of a different household) tries to connect; there is no response. It just waits until it times out.

For more details about "what happens":
If I open my website on my local computer, it shows up, no problem. If I open the webpage on any other computer on the same router, it shows up, no problem. If I tries to open it in another household on a different router, it tires to load but nothing happens, it's a white page util it's timed out.

I'm using the external IP-address, which I found at What's my IP.org
I've looked trough multiple pages trying to find the problem.
I'm letting IIS trough the firewall, even disabled the firewall.
IIS, Network Service, Anonyms Login has permission to read and run the root folder (inetpub)
Should not be any conflict with server-names; new name each time.
I have never before changed anything in the router to get it to work before. And there's no settings on it either, just a wireless restart option.

I'm running:
• Windows 8 Pro - Swedish
• IIS 8 (8.0.9200.16384)
• Windows Firewall
• Telia router/modem

share|improve this question

migrated from serverfault.com Feb 1 '13 at 1:04

This question came from our site for professional system and network administrators.

    
If people have some experience with common problems, please suggest anything. If you want me top diagnostic anything, I can do that. Voting it down and telling me that it isn't elaborated enough isn't helping me at all. What do you want ko know?... –  Liggliluff Jan 31 '13 at 21:21
    
You're question is probably being downvoted because development environments or lab/home environments are off-topic. Please read the FAQ. –  kce Feb 1 '13 at 0:23
add comment

1 Answer

Take a look at your router, you must forward your 80 port to your LAN server IP address.

share|improve this answer
1  
Yep. And portforward.com (as well as lots of other sites, of course) has instructions on how to do that on most routers. –  Marcus Chan Feb 1 '13 at 1:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.