Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using gvim on Windows 7.

My question relates to the Edit File dialog box that appears when File->Open is selected from the gvim menu bar.

At the bottom right of the Edit File dialog box is a file types selector that allows filtering of the displayed files based on their extension. The default selected option is the extension matching the file in the current buffer. For example, if I have a '.xml' file open when I attempt to open another file, the default selected option is 'XML Files (*.xml)', so unless I change the selected option, I may only browse for XML files. Since I work on files having many different extensions, I find myself having to change the selected option almost every time I open a file.

I wish to change the default selected option of the file types selector to be 'All Files (*. *)'. Does anyone know how to do this?

share|improve this question
up vote 1 down vote accepted

If you use File > Open, you're using Vim wrong. Use :edit, write your own mappings for custom locations, or use one of the various file finder plugins (FuzzyFinder, CtrlP, ...) found on

That said, the file filter is set by some filetype plugins. To turn it off, the b:browsefilter variable needs to be cleared. To have this done automatically, put the following into your ~/.vimrc:

:autocmd FileType * unlet! b:browsefilter
share|improve this answer
I confirmed that the .vimrc tip solves the stated problem. As for using :edit, I find browsing useful because most times I open a file I either can't remember the exact path or don't know which file I'm looking for and need to decide based on the filenames I see. I found that :Ex opens a text-based file browser in vim. I'll start using that instead of File->Open. – Tom Feb 3 '13 at 23:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.