Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Going to http://teamtreehouse.com/ in IE 9.0.8112 the video on the right comes up and shows the still image. You click the image, and it plays fine.

I have Firefox 18.0.1 as my primary browser. When I go to that site, the still picture does not show, nor will the video play if you click on it. If I go to that page, and look at firebug, I see some "403 Forbidden" errors.

I thought this might be an mp4 issue, but I was able to watch mp4 video on another site. (QuickTime in browser plugin)

Looking for any suggestions to get this working in Firefox or how to troubleshoot this further.

Update: In the error console I see a lot of "Warning: Unknown property '-moz-border-radius'. Declaration dropped." warnings and I see errors similar to "Error: [Exception... "'Image HTTP->HTTPS redirection to https://a248.e.akamai.net/...3cf7.png' " but nothing relating to video.

share|improve this question
1  
Works for me. Does the Error Console (Ctrl + Shift + J, clear the console and reload the page) show anything? Do you have another browser you can try? Have you tried a hard-refresh (Ctrl+F5)? –  Bob Feb 1 '13 at 14:10
add comment

1 Answer

The picture appears for me using Firefox. It may be due to some add-on or configuration setting in your Firefox profile. Try creating a new Firefox profile and checking the site using that profile.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.