Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My system shows an error message;

C:\Windows\system32\wow64.dll is either not designed to run on windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support.

This message appears when trying to open all programs, internet explorer, windows live, office suite programs etc.

How can I fix this?

share|improve this question
I have edited your question to remove your contact information as it is not allowed per the faq. Also, do not put personal contact information in your posts. – CharlieRB Feb 1 '13 at 14:34
Now for my comment; what have you tried or researched on this? Run any scans? Restore to a previous time? Safe Mode work? – CharlieRB Feb 1 '13 at 14:38
@CharlieRB..I have performed restoration, ran sfc / scannow but still problem persists. Please help me.Thanks. – Himanshu Feb 4 '13 at 5:44
Based on this error I would just reinstall Windows. – Ramhound Feb 4 '13 at 14:34
I have reinstalled the windows. Everything is perfect now. Thanks. – Himanshu Feb 7 '13 at 6:13

I started experiencing the WOW64.DLL error when my Windows updates failed. I spent a total of 9 hours battling this issue as no application or internet browser launched causing more frustration. I finally resolved this issue with the following steps:

  1. Procure a copy of WOW64.DLL located at C:\Windows\System32 from a different Windows 7 PC (I used a friend's PC). Copy it to a USB drive.

  2. Restart your PC in Safe Mode (press the F8 key during the boot process).

  3. Navigate to C:\Windows\System32, right-click on Wow64.dll and select Properties.

  4. Within the Wow64.dll Properties window, go to the Security tab and click on Advanced.

  5. Go to the Owner tab and change the Owner to Administrators (the current owner normally would be TrustedInstaller). Alternatively, this can also be achieved using an elevated Command Prompt:

    • Within the elevated Command Prompt, navigate to C:\Windows\System32

    • Enter the following command:


      You should receive a confirmation message saying "SUCCESS: The file (or folder): "filename" now owned by user "Computer Name\User name"."

    • Upon success, enter the following command:

      ICACLS WOW64.DLL /grant administrators:F
  6. Delete or move your current Wow64.dll to a different folder.

  7. Copy the external copy of Wow64.dll (from step 1 above) to your system's C:\Windows\System32 folder.

  8. Restart your PC normally.

These steps resolved my issue.

share|improve this answer

Try using opening the command prompt with administrative privileges and run

sfc /scannow
share|improve this answer
I have performed restoration, ran sfc / scannow but problem still persists. Please help me.Thanks. – Himanshu Feb 4 '13 at 7:38
Try to boot into safe mode (hit F8 repeatedly when the system boots, or hold it) and run sfc /scannow from here. Try also regsvr32 /s wow64.dll – Pincopallino Feb 4 '13 at 12:00
I have reinstalled the windows. Everything is perfect now. Thanks. – Himanshu Feb 7 '13 at 5:35

I had the same issue and all of provided instructions did not work. What worked for me is to finish all the updates.

share|improve this answer

This is an excerpt from this Microsoft Answers post.

Windows Live Media have these four dll's linked to them;


Manually register the dependent .dll files for this error and see if this resolves the issue.

To do this, click the Start ORB / in the Search Line Type Command / Right Click on the Command Prompt from the programs list / Select RUN AS ADMINISTRATOR.

In the command prompt type regsvr32 /s ntdll.dll and hit enter,
then regsvr32 /s wow64.dll and hit enter,
then regsvr32 /s wow64win.dll and hit enter,
then regsvr32 /s wow64cpu.dll and hit enter.

You've not answered whether Windows works normally in Safe Mode. It is recommended you try as @pincopallino suggests to run sfc /scannow while in Safe Mode. After that, try uninstalling Windows Live Essentials and reinstall it.

If you are still having trouble after that, you may want to do a factory recovery to start from a fresh install of Windows.

share|improve this answer
I have reinstalled the windows. Everything is perfect now. Thanks. – Himanshu Feb 7 '13 at 5:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .