Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Installed Windows 7 in Virtual Box, and started old (from 1999) game in it. All worked fine, but on exit from game, Windows switched to 256 colors. And it's virtually unusable. Some buttons are black on black.

Is there any way to switch windows again to normal 24/32bit color depth?

share|improve this question
add comment

2 Answers 2

You can change it by:

  1. Right clicking desktop
  2. Clicking "change resolution"
  3. Clicking "advanced settings"
  4. On the "monitor" tab at the bottom you can change the colors.

enter image description here

share|improve this answer
    
Ah. So it's select. It displayed as a text for me :( Thanks. –  user7385 Feb 1 '13 at 20:25
    
NP, I was honestly expecting to troubleshoot an issue with the Vbox experimental 3d acceleration driver. Glad it worked out this easy... –  Kyle Feb 1 '13 at 20:27
    
Well, not so fast - apparently - the select in my vbox shows only 256 colors. I was able to find mode change, but somehow - there is no native 1920x1200/24bit. the most in 24bits i can have is 1600x1200. Which is better, but why can I have, as previously, 1920x ? –  user7385 Feb 1 '13 at 20:33
    
@depesz Nice, Mine is able to do 1920X1080 @ 32bit color so it's not a Vbox limitation. I would suggest turning off 3d acceration and 2d acceleration with the VM off, booting, shutting down, turning it on again, then checking your color settings. This will unload the 3d acceleration driver then reload it again. I have so many weird problems with that driver and Aero enabled.... Also try simply disabling then re enabling Aero. –  Kyle Feb 1 '13 at 21:09
    
both 3d and 2d acceleration are off. aero is off. and always was. –  user7385 Feb 2 '13 at 1:06
add comment

Open up the taskmanager and make sure that the game process has exited, if not, then end it.

Sometimes a process (specially old games) use different color settings to display, and simply closing them might not end the process properly.

(happened to me playing AOE2)

share|improve this answer
    
The vbox was rebooted. Several times. –  user7385 Feb 1 '13 at 20:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.