Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get data from a W800USB RF receiver. The ftdi_sio driver handles the device:

[ 7279.231457] usb 1-1.2: New USB device found, idVendor=0403, idProduct=6001
[ 7279.231474] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 7279.231485] usb 1-1.2: Product: FT232R USB UART
[ 7279.231493] usb 1-1.2: Manufacturer: FTDI
[ 7279.231501] usb 1-1.2: SerialNumber: A4007TCh
[ 7279.707642] usb 1-1.2: reset full-speed USB device number 8 using ehci_hcd
[ 7279.935302] usb 1-1.2: reset full-speed USB device number 8 using ehci_hcd
[ 7480.130761] ftdi_sio 1-1.2:1.0: FTDI USB Serial Device converter detected
[ 7480.130866] usb 1-1.2: Detected FT232RL
[ 7480.130872] usb 1-1.2: Number of endpoints 2
[ 7480.130877] usb 1-1.2: Endpoint 1 MaxPacketSize 64
[ 7480.130881] usb 1-1.2: Endpoint 2 MaxPacketSize 64
[ 7480.130919] usb 1-1.2: Setting MaxPacketSize 64
[ 7480.131695] usb 1-1.2: FTDI USB Serial Device converter now attached to ttyUSB0

Then I do:

cat /dev/ttyUSB0

and start sending RF signals from a DS10A but there is no output. I tried using gtkterm and set baud rate to 4800, 8 bit, 1 stop bit. There is no data. I tried to send 0xf029, there is no reply.

I installed VMware on the same computer, on Windows XP within VMware, powerhouse software can receive data from the device. And I can't see any data request messages from the serial port monitor. I spent hours on this thing but could not receive a single byte from Linux. What am I doing wrong?

Fedora (3.7.4-204.fc18.x86_64), tried on two computers with the same configuration.

share|improve this question

The answer comes in the form of:

sudo yum erase ModemManager
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.