Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been given a job: open a XXXX.vhd file and extract datas from an SQL folder. The problem is that I've tried this:

  • install "WMWare" then open it. "File unknown" as a result.
  • install "Oracle VM VirtualBox" then open it. "File unknown" as a result.
  • install "VHD Attach" then right click => attach then i go to the "Disk manager" and here's the problem, when I right-click on it: all possibilities are greyed. Why? What could be the solution?

Disk Manager greyed menu

As a hint, I've been told there has something to do with Linux.

Any idea?

share|improve this question
What exactly has something to do with Linux? If you don't provide us more information we can't really help. The only reason you wouldn't be able to attach and view the contents of a .VHD file within Windows 7 is because the version your using doesn't support it. You should have no problem using Virtual PC and loading up the actual operating system to access the data you want. If you want to use VMWare then convert the image. – Ramhound Feb 2 '13 at 0:50
"If you want to use VMWare then convert the image.". Thank you, I'll search for this on the web – Olivier Pons Feb 2 '13 at 6:43
up vote 0 down vote accepted

Possibly there's an ext2/ext3/ext4 partition on that disk. Windows only supports FAT and NTFS partitions. ext is an Linux partitions format, so you need Linux to read it - or maybe Explore2fs or Ext2explore will do the job.

share|improve this answer
explore2fs-1.08beta9 didn't work – Olivier Pons Feb 1 '13 at 23:12
Then give Ext2explore a try. Explore2fs doesn't support the latest ext4 format. – gronostaj Feb 1 '13 at 23:17
I've tried. This doesn't work, but it showed that there are 3 partitions: the first one (102Mb) it ext3, the second is "RAW" and third is "RAW" too. If I have to go under Linux how should I do? Which program? Thank you for your answer – Olivier Pons Feb 1 '13 at 23:22
"Raw" format should be taken literally - there's no file system on that partition or it's corrupted. Or maybe VHD is corrupted and it's the reason why VM software can't even touch it and what other apps show doesn't make any sense. Try attaching original file, as this copy may have been changed by VMware or VirtualBox. Also, Ext2explore is capable of opening some drive images - maybe it could handle VHD. Also, it looks like 7-Zip can open those too. – gronostaj Feb 1 '13 at 23:30

Windows 7 Enterprise and Ultimate editions support VHD, both with and without a host operating system present. You should be able to use the file on those systems.

share|improve this answer

Use 7-zip to open that VHD. It opens all VHDs that I have.
If it has Linux partitions, then you can try Paragon Ext driver for Windows it supports Ext2/3/4 partitions. Also try Linux live distros like Ubuntu Live.

However you mentioned that VMWare couldn't open it.
Maybe image was damaged? Or maybe it has such unknown file system that even VMWare can't recognize it?

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .