Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got my Windows 7 Operating System acting weird lately, when I insert a USB flash drive, it says that I must format it although it already has a valid file system. I've tested them on my friends' Computers and they seem to work well. If I click the format button, I get a message saying that Windows was unable to complete the format as below

Windows was unable to complete the format.

I've tried changing the drive letter, checking for malware and/or viruses, re-installing the drivers, checking for Windows updates but nothing unfortunately seemed to work. It's also worth mentioning that the USB Hub was working perfectly 1 week ago, but it is not working properly now. I have no system restore points and I'm not really willing to re-install Windows.

Any help will be greatly appreciated :)

share|improve this question
I don't mean to patronize, but you mention the hub not working. I assume you tried it not through a hub? How about other drives than that one, do they work? – nerdwaller Feb 2 '13 at 3:01
@nerdwaller I don't know whether the problem is related to the hub or not, but I'm sure it is not related to my flash drive. I can only insert the flash drive through my hub, maybe this problem is software related? What may cause this to happen? Thanks for your comment :) – Daniel Feb 2 '13 at 3:10
What do you mean that is the only way to insert the drive? If it's a laptop, there should be a few options to try. If it's a desktop, then you have the front or back panel to try it in... By "hub" I assume you mean external USB hub? Is it powered? Try another (anything) USB in it to narrow it down to the hub or computer, then worry about whether it is drivers or something else. Otherwise, trouble shooting is moot. – nerdwaller Feb 2 '13 at 3:36
@nerdwaller I think that it's the only way right now to insert the USB stick. It's a desktop Computer and the hub is not external, I don't have any external USB hubs at the moment. Thanks for your time :) – Daniel Feb 2 '13 at 13:19

I see two different things....

  • One or more ports on your hub might be malfunctioning. Try others and see if you have the same problem.
  • Your hub is malfunctioning. See if you can plug in your USB stick directly without using that particular hub.
  • Your USB stick might be of marginal quality and operating at one of the margins, but outside the margin your system, hub, or ports might accept.

Summary, do a little detective work to logically eliminate possibilities.

share|improve this answer
Thanks for your suggestions. It appears that all the ports won't accept the USB flash drive. How can I plug my USB stick directly? I only have the hub. Maybe the hub is malfunctioning, but can't it be a software problem? – Daniel Feb 2 '13 at 13:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .