Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I haven`t installed VirtualBox on my linux-mint-debian-edition system.
Today,when I startx,I got this responses on my displayer:

/etc/mdm/Xsession: Beginning session setup...
localuser:sofa being added to access control list
fcitx 使用的 script 从 run_im 启动。
auto 使用的 script 从 run_im 启动。
default 使用的 script 从 run_im 启动。
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
OpenSSL version mismatch. Built against 1000007f, you have 1000103f

````````````````
thanks in advance!

share|improve this question

migrated from serverfault.com Feb 2 '13 at 14:27

This question came from our site for professional system and network administrators.

2 Answers 2

Make sure you have dkms installed.

apt-cache search dkms | grep '^dkms'
dkms - Dynamic Kernel Module Support Framework

If this is the case try the following:

$ sudo /etc/init.d/vboxdrv setup
share|improve this answer

I had the same problem on Fedora Core 20 - "failed to connect to the virtualbox kernel service" message and no proper screen resize in the VBox (black borders around the small OS Window). In my case the problem was in te SELinux. Probably it didn't allow some modules to load because of wrong context - I didn't dig deep enough.

After I switched SELinux into permissive mode -


Edit the file /etc/selinux/config

Set the param SELINUX=permissive

Reboot


everything worked fine and the resolution on Vbox is now adjusting to the size of the VMBox window.

I know that turning SELinux in permissive mode is not the best option, but it may narrow your problem and help you find out your root cause.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.