Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently gotten a new USB drive, and the problem is, whenever I plug it in, it just shows up as an unknown device. It also won't install the driver. So, basically, I can't use my USB, which is obviously a problem. I've already tried a lot of solutions, and trying to use the troubleshooter promptly gives me an error (sdiageng.dll isn't valid or something). I've tried using the USB with other computers, works perfectly fine. I've got Windows 7 btw. Thanks in advance.

Note : I'm translating all the window names, like troubleshooter, etc. from Dutch, so bear with me.

share|improve this question
    
Disconnect drive, run USB Oblivion, reboot and try again. Also, if it's USB-powered, try with both USB plugs (some drives have a Y-type cable). If this helps then most likely your USB port is not supplying sufficient power to run the drive. –  Karan Feb 2 '13 at 17:03
    
The USB oblivion didn't work. –  user194882 Feb 2 '13 at 17:50
    
Do other USB drives work fine on the same PC? –  Karan Feb 2 '13 at 18:01
    
No, that's the funny thing, I used to have another usb drive, like, 2gb, can't remember the name, and it worked fine. the USB I'm talking about right now is the Kingston DT 100 G2 16 GB. –  user194882 Feb 2 '13 at 18:02
    
Did you try it on all the USB ports? –  Karan Feb 2 '13 at 18:04

2 Answers 2

Try to update your USB drivers as well as you chipset driver.

share|improve this answer
    
This is the correct answer. –  Josh Campbell Feb 2 '13 at 20:02
    
I've already tried updating my drivers, it says that it requires an interactive windows computer (?). Thus resulting in nothing happening. Also, what's a chipset driver? –  user194882 Feb 3 '13 at 13:16
    
Alright, so, figured out with a chipset driver is, updated it, didn't work. –  user194882 Feb 3 '13 at 13:39

YES ! I fixed it. The trick was to go into devices and printers, and then right click uninstall, reboot, and now it's just in the list of storage, things, in computer.

share|improve this answer
    
I'm glad you worked it out. Since you updated your chipset drivers. The computer would start detecting hardware, after you removed the ghost driver assigned to your USB device Windows will pick up the right one upon restart. Good Job man. :-) –  Juan Carlos Feb 5 '13 at 15:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.