Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Remove the write protection from an USB flash disk
Cannot write, format, nor erase flash drive

Recently i just came across this problem, my usb doesn't seem to work anymore as i'm not able to access it or pretty much do anything to it. It says it is corrupted therefore i tried to format it as i already have backed up my files. However, it does not format because it is 'write protected'. i tried many ways to disable this, i have tried:

  • Using registry edit and putting write protection to 0
  • Using DiskPart
  • Used different types of formatting tool
  • Used Linux or whatever it is

Does anyone have any solutions for this, because everywhere i searched no one seems to have an answer Thanks. :)

share|improve this question

marked as duplicate by Karan, Ƭᴇcʜιᴇ007, Dennis, TFM, ChrisF Feb 3 '13 at 13:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
Can you narrow 'a HP USB down'? Right now it is a 'How do I replace and engine on a $brand car', without telling us the model. –  Hennes Feb 2 '13 at 19:04
    
oh sorry, um it's a HP 2GB v165w –  Bridget Feb 2 '13 at 19:08
1  
Possible duplicate of Remove the write protection from an USB flash disk, How can I disable write protection in my USB flash drive?, Cannot write, format, nor erase flash drive and many more. In most such cases I've found that the drive's corrupted and irrecoverable. –  Karan Feb 2 '13 at 19:14
    
Do you get the same wrote protect error if you try to format it on another computer? Or if you plug it into another computer and use diskpart and clean? (Double check that you have the right drive before issuing the clean command!). Did you enable readyboost on your computer ? –  Hennes Feb 2 '13 at 19:17
    
yeah, i tried everything on my laptop and my computer and i just seem to have the same result on both. i'm not sure how readyboost will help? i do have it though, yes. –  Bridget Feb 2 '13 at 19:20

1 Answer 1

HP appears to have special ways to do things. If using fdisk or parted in "Linux or whatever it is" gives you no luck, try HP's Disk storage format tool

Although it is possible the device has been physically damaged (this happens to USB pendrives every now and then). In that case your best bet would be data-carving software like PhotoRec, it is available for Windose too so you dont have to bother with "whatever it is."

If you do not have any data of value on that thing, I suggest you go buy a new one. They are cheap.

share|improve this answer
    
yeah i already tried HP's Disk storage format tool but still same response. i'm not sure what PhotoRec is. And yeah i know but i thought i might as well try and fix it if there is a way but if not then yeah i know what to do, no harm in trying. –  Bridget Feb 2 '13 at 19:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.